[Solved]Problem with switching to jbullet in jme 3.1 alpha 5 SDK

this problem is specific to alpha 5 SDK and works fine in previous versions.
I was trying to switch from native bullet (which is default in alpha 5) to jbullet in alpha 5. for switching i simply removed jme3-bullet and jme3-bullet-native libraries and added jme3-jbullet library.

then tested physic with “Jme Tests” project also other test codes but for all of them i got this error :

java.lang.NoClassDefFoundError: com/bulletphysics/collision/dispatch/CollisionConfiguration
        at com.jme3.bullet.BulletAppState.startPhysics(BulletAppState.java:164)
        at com.jme3.bullet.BulletAppState.stateAttached(BulletAppState.java:211)
        at com.jme3.app.state.AppStateManager.attach(AppStateManager.java:133)
        at mygame.TestGImpact.simpleInitApp(TestGImpact.java:37)
        at com.jme3.app.SimpleApplication.initialize(SimpleApplication.java:220)
        at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(LwjglAbstractDisplay.java:130)
        at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:211)
        at java.lang.Thread.run(Thread.java:745)
    Caused by: java.lang.ClassNotFoundException: com.bulletphysics.collision.dispatch.CollisionConfiguration
        at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
        ... 8 more

@Darkchaos you may have some hint about it. If i remember you made native bullet to be default in SDK alpha 5. So may this bug relates to that change ?

Can someone with SDK alpha 5 also test to see if it is a bug or … ?


I guess this is because the 3.1 maven artifacts don’t contain our jbullet.jar


but in SDK alpha 4 and previous versions i can switch between jbullet and native with no problem.

Yeah because that was built as one big project (engine+sdk), now the SDK is separated and gets the jars from maven.

Yep, normen is right, i just tried it.
If you add stack-alloc.jar and jbullet.jar it works like it used to.


Thanks so much guys. :grinning:
Added does two jars and it works OK.

But not know why there was no warning by Netbeans about missing does libraries.:confused:

Anyway a great thanks.

It’s strange because I would expect any pre-alpha5 project to not work then since it misses jBullet.
Which should look into that issue though because the SDK seems to have Problems with missing jBullet Classes as well…

Maybe it’s missing those jars?
Could anyone try that? (I’m talking about this LinearMath MotionState Thing (Adding a RigidBodyControl or HoverTankPhysicsTest)