[SOLVED] SDK 3.3 and GUI issue

Hello, I am running WIN11, Radeon 6900XT, i7 12700k. When I start up the SDK and look around the options menu after about a min the screen starts to not render correctly anymore, menus are all over the place and the IDE is completely unusable. Anyone else see this behavior?


What did you do to reproduce this ? Also i think if you can capture a screen record, it will help in defining the issue ?

Hello. I will try to post a video of it this week. Thanks for helping

Yeah, this is typical to Swing :frowning: Usually more prominent with NVIDIA. You can try to see if you have the latest graphic drivers. I haven’t found any fix to this issue. You can try some compatibility modes etc. It is really annoying :frowning: I see this also in other like Sweet Home 3D. Have been there for ages…

And weirdly enough it doesn’t happen when I run the SDK from sources (the same snapshot than the release). But with the installed version it happens immediately in Windows. In Linux I have no problems with this.

This makes it sound like it’s related to the Java2D settings that can be switched on the command line. It’s been a long time but something related to DirectDraw.

Perhaps the installed .exe version has passed that Java2D=DirectDraw thing on the command line and when you run the built from source version it does not.


You mean this:

Maybe this can be used also instead?

Hmm, could these be tested via the netbeans.cfg or whatever the config file was that allows to change the NB JVM params…

1 Like

If you have VisualVM, you should be able to hook into the actual running SDK, and it will display the options that the JVM was started with. There may be other tools to check this, but it’s my go-to for this sort of check.

1 Like

Now that you mention that, jconsole can be used for the same and comes with Java.

Here are the corrupted images…


Can you run the regular netbeans without those rendering problems ?

1 Like

@SyntheticPrime did you try to set these? To the netbeans.conf file? I don’t have access now, but I think it was in the installation directory somewhere.

I didn’t find the netbeans.conf file anywhere. Searched in the jmonkeyplatform directory. …

for linux it can be for example:


for windows for example:

C:\Program Files\NetBeans 8.0.1\etc

its Netbeans so internet have knowledge where the file is.

1 Like

Didn’t have Netbeans installed. Only JM SDK

I did DL NB13 just now and ran only the NB IDE, no JM SDK and no issues there but uses JDK 18…

1 Like

Are you sure ? Have you searched it ? it should be within your netbeans installation dir, the prompt of netbeans location you get while installing…

If in doubt, use the dir windows command:

dir C:\ netbeans.conf \s

On linux you can use find / -name netbeans.conf or dir / -R netbeans.conf.

The one for jMonkeyEngine sdk is under jmonkeyplatform/etc/jmonkeyplatform.conf.

1 Like

Well, if you have JME SDK Installed, in fact you have Netbeans installed, since SDK = edited Netbeans (dont remember what versions it was). Like mentioned above config file name might be different.

BTW. before fix, you can use any other IDE. No need use SDK.

For example i currently use Intellij IDEA + Gradle(JME packages) and its all i need.

OFC it would be very good if fix SDK issue, i just say that for “temporary before fixed” there are alternatives.

I put the

in the jmonkey config file in the ect dir. No luck. Behavior is the same.

I will see if I can setup NB or try your solution. Bit rusty been away from coding for awhile. :slight_smile: