[SOLVED] SDK wrong screen resolution

EDIT: Link to solution

Setting -J-Dsun.java2d.dpiaware=true in /etc/jmonkeyplatform.conf did the trick :+1:

This seems to be a common problem in netbeans releases with UHD/4k screens.

Original post:

Hello everyone

Upon starting the newly installed release of v3.2.1-stable-sdk3 the SDK doesn’t seem to use the right screen resolution. Its appereance is way too small in comparison to any other application. See screenshot attached comparing it with the resolution of the browser / explorer (Running Windows 10).


I’ve searched for similar problems and haven’t found anything helpful yet. The settings within option - appearance don’t seem to have adjustments that would fix the problem. I hope you can help me with it.

I tried to set --fontsize within /etc/jmonkeyplatform.conf with no visible effect. Native setting in Windows usually scale text 300% to make them readable. How do I adjust the settings / .conf so I can work in the SDK without using a monocle magnifying glass?

I had the same issue. I googled netbeans font size and found something similar to what you’ve done I think. Worked out for me.

Thanks, I digged some more with netbeans in the search parameters and have found a solution with this .

Changing -J-Dsun.java2d.dpiaware to true in /etc/jmonkeyplatform.conf did the trick.

1 Like