[SOLVED] Some assets could not be loaded - Have I missed something in Blender?


#1

Hello!

I have this model in Blender.
Markering_028

And I using this page to convert the .blend file to .obj file, which I’m going to use as a model in JME. I didn’t get Ogre to work.

https://www.meshconvert.com/

But then when I try to import the model inside JME.

Check if the model looks as expected, some textures fail to load. Textures that can not be found will be replaced with a red material.
You can also apply textures later by copying them to the project folder and applying them via a j3m material.
The UV coords are saved in the mesh so the mapping data will still be available.
With the buttons above you can move the camera.

Question:

Do I need to insert material, texture etc. inside Blender on my model first?


#2

So, uh, doesn’t blender have a built-in .obj exporter? If ogre didn’t work, you can try importing .blend directly or one of other supported formats (xbuf, gltf…).


#3

I haven’t notice that for now. I did try it out and it works. Thank you!.


#4

By the way! What’s the reason Ogre exist and seems to be so popular here?


#5

It was the first properly working asset import format. Even now some specific animations can only be imported by ogre. After ogre, blender importer became relatively stable, then xbuf aimed to perfect animations (can’t tell if it did, haven’t used it much) and these days gltf is aiming to be an open engine-agnostic format.


#6

And so far, for me… gltf is working great. I don’t use anything else anymore. (GLTF is not without a couple issues but I fortunately have not hit them.)

As to the original question, at the time, ogre was the only format able to support animations… and indeed much of JME’s original animation system was based directly on the ideas in the ogre format.


#7

Thank you all!

I got the obj model working. I need to set some material on it first. Why is it transparent?


#8

Perhaps some of your face normals are backwards.


#9

But it looks great in Blender.


#10

Blender renders both sides of the mesh, but the engine only renders the front side by default for performance.

To fix it in blender, Select all of the object’s vertices in edit mode and press ‘ctrl + n’ to fix the normals to face outwards.

You can also press W in edit mode, and select “flip normals”. In blender, you’ll notice the shading of your model changes very slightly when you flip the normals - that’s the only visible way to see the normals when viewing the object in blender.


#11

…unless you have the properties panel open and turn on view normals…


#12

Thank you.

Can can see the same color in blender as in the in import wizard in JME, but when I look at the SceenComposter, I cannot see my model. Is there any way to do a fitting zoom?

Got a error:

" Edge or polygon detected in OBJ. Ignored."


#13

Solved the problem. I just need to re-mesh the object. Now I need to find my object in the SceneComposter view. It will be a lot of scrolling now.


#14

I’ve had this issue too sometimes, usually when I’m working on a large scene and close the scene while the camera is at a position far away from, and looking away from the origin of the scene.

Usually I notice it fixes itself after I close and re-open the SDK. You could also try pressing the “window” tab at the top of the SDK and click ‘reset windows’, and see if that resets the camera’s position in the scene composer too.


#15

Tank you! I had to scale down my model, then it works fine.