[SOLVED] Space key is not recorgnized anymore

Hi there,
a few days ago, when I had just added a small nifty start page to my current project, the space key wasn’t recorgnized anymore during the gameplay. For testing I replaced it with the right controll key within the keymappinggs, wich works fine. Because I was able to use the space key for normal purposes in the IDE and the sourcecode, my first thaught was, that this is one of those windows mysteries which are vanished after the next reboot. But I was wrong. The last days I tried a few times to switch the keymap back to vk_space but the key seems to be not recorgnized anymore. Is it possible at all that this behaviors has its cause in JME or is this maybe caused by os or hardware?

1 Like

Do you mean “nifty” as in the nifty user interface library?

If so, maybe try removing the page and see if it still happens.

Other than that, we’d need to know things l like which version of JME you use, which lwjgl you are using, etc.

Nifty uses several keyboard keys to navigate among GUI controls (for users who don’t have a mouse or whose mouse is disabled):

  • Tab or DownArrow : selects the next control on the screen
  • Shift+Tab or UpArrow : selects the previous control on the screen
  • Spacebar or Enter : activates the selected control

I don’t know any reason why the Control keys would be affected.

I’ve never tried to disable these mappings. You might try InputManager.clearMappings().

99.999% sure that the nifty GUI library adds a raw input listener and does not use regular input manager mappings.

1 Like

Thanks, next time I am in it I comment the Startscreen Out and give it another try.

1 Like

Yes, it was the Startscreen. I’d forgotten to change nifty to the hud after the start button is pressed. Sorry I’d botherd you all and thanks for your help!

1 Like