[SOLVED] There is a problem parsing the package

I’m testing a basic jme project (the automatic generated game with blue box and you fly around)
But when I build, send the file to androud and tried to install I got “There is a problem parsing the package” error message :confused:

I have tried resending the apk file to my android but it still gave me the errors
also I tried checking “Unknown access: allow installation of apps from sources other than the Play Store” on my Android but it still doesnt’t work

What I have done:

  1. Create a new project
  2. right click the project and go to properties
  3. Unchecked “compile on save” under “Compiling”
  4. checked “adroid deployment” with Android Target 4.0.3
  5. build
  6. build success, with a warn please sign the apk manually
  7. send the apk file to the android device with bluetooth
  8. tries to install
  9. fail with the error: There is a problem parsing the package

I’m using SDK 3.0 and My android version is 4.2.2

please help!

1 Like

Have you tried:

  • setting the project configuration to android
  • run the application

Yes, I have setted project configuration from “default config” to Android Device
I tried run the application with USB but for some reason it doesn’t connect with my Android Device and it just say:

Waiting for device to be ready.. Connect your device now if its not connected yet.

You need to install usb support for your phone, on your desktop. I can’t remember what I googled, but if you look for it you should find it. That is the error message you get when you ae missing that install.

how do I find usb support for android?

Tried on my other Android Tablet with v. 4.0.4, still not working.

solved the problem, you need to sign the apk to install on android