[SOLVED] ToneGod bug from the 3.1.2

Hello, i just decide to change my jars up to the 3.1.2, (and so far so good :smiley: Good job btw) but i got this bug :

Uncaught exception thrown in Thread[jME3 Main,5,main]

NoSuchMethodError: com.jme3.renderer.ViewPort.getScenes()Ljava/util/List;

Turn out it come when you init the scene cause of this line (in the toneGod librairy):


But you just comment it and everything work fine. Not sure what its suppose to do, but look like it should be remove.

Anyone have futher info?

Have you tried uncommenting it again?

Likely the rebuild is what fixed it.

Yep, try it and did not work. But strangely, it seems like it doesn’t do anything. I know it’s a very dangerous thing to say, but everything in my interface still works really fine whiout it.

I would just love to see someone else who uses tonegod confirm/Infirm me this. I may have failed a manipulation in the installation, but it I don’t see where.

Well, the error indicates that a recompile of that line was all that was needed. As often is the case for that type of runtime error.

The method signature changed but it is otherwise 100% compatible. getScenes() used to return a straight java.util.List but now it returns a SafeArrayList instance. Recompiling the class making the call should have been all that was necessary to fix it.

…and if not, then something is wrong with your build process (like still compiling that code against older JME jars). Else the code itself is fine.

1 Like

Okay turn out you where right (again x) It was my manip on the jars import. Only thing now is that i had a few interpolate to change into interpolateLocal.

I should really learn how to use gradle. :chimpanzee_confused: