[SOLVED] Unable to launch installer app on macOS

I downloaded the jmonkeyplatform-macosx.tgz of v3.2.1-stable-sdk2

Then when I double click on the installer app, the app icon shown up on the dock and disappears soon. I also tried “show package contents” and run the executable file and the terminal says that i should install jdk, but I have jdk installed on my mac.

I have searched on this forum for my question and solutions like modifying the .conf file would not work because I don’t even have that file.

My system is macOS High Sierra 10.13.3 and java version is “9.0.4”

This should be fixed in sdk2 actually. Can you Double Check that you dont have an old version?

Maybe the bug persists. The conf file is only available after installation.

It would really help if you could show us the logs (open jMonkeyPlatform.app in Terminal)

A Workaround could be installing java 8 (and possibly removing java 9 if possible)

I launched the app in the terminal and it shows:

LSOpenURLsWithRole() failed for the application /Users/user/Downloads/jMonkeyEngine SDK Installer.app with error -10810.

Then maybe cd into that folder and in MacOs (there should be the executable, maybe you can launch it directly)

Thank you, the problem has been solved by installing java 8 and removing java 9

1 Like