[Solved]Update won’t update

I just reinstalled jMEPlatform and the updater won’t completely update to the newest version. The reason I know for sure is that bullet.nodes were deprecated and my import statements aren’t saying they are. Not to mention a bunch of other features aren’t available.

Any suggestions?

Did you ever have the javadocs open in your browser? I had a problem where firefox was holding the javadocs zip open until I killed firefox. May not be your issue but I thought I would mention it.

I checked javaDocs after I noticed the use of the deprecated class. I knew it was deprecated when I used it initially, but figured it worked and I’d fix it later. And now a bunch of other classes that I use just aren’t there. I know for certain that I am not up to date, but the updater says I am.

What I mean is that firefox was locking the old javadocs from being removed and so leaving firefox open was preventing the update from completing. My symptoms were similar. I found out because I tried to manually move the old stuff out of the jmonkeyplatform/lib directory and windows wouldn’t let me.

Closed all programs and tried to update didn’t work. Restarted and didn’t run any other programs. Checked the update and didn’t work. I’m going to uninstall again, re-download the installer, install, and check the updater. I’ll do this when I get home and report back.

After a long session of trial and error I found the solution. When it asks if you want to restart now or later i chose later. Then, closed the program myself and made sure it wasn’t running by checking the taskmanager. After I started it back up the updates actually happened.

1 Like