[SOLVED] Visual artifacts in sdk / compiling fails(dl.bintray.com forbidden)

First time using the engine, and sdk.
The sdk feels sluggish and laggy(not too important, but could be related)…
I tried the netbeans 12.4, and it works fine.

The launcher and the SDK ide both have visual artifacts. The artifacts on the launcher start when I want to change the resolution, before starting the game .
I run amd FX 8350, AMD R7 360;

The ide works correctly on a laptop running linux.

oh, and I can’t build from source, because when I run ./build_engine.sh
I get Can't get https://dl.bintray.com/jmonkeyengine/files/9f026b41ca0cab34042262a830a3979107721da1/jme3-natives.zip Forbidden!

similar, when I run ./gradlew run, I get `Execution failed for task ‘``:downloadAvian’.

java.io.IOException: Server returned HTTP response code: 403 for URL: Global Software Distribution & Software Releases - JFrog Distribution

The system I tried to build on:

$ ./gradlew --version

------------------------------------------------------------
Gradle 5.6.4
------------------------------------------------------------

Build time:   2019-11-01 20:42:00 UTC
Revision:     dd870424f9bd8e195d614dc14bb140f43c22da98

Kotlin:       1.3.41
Groovy:       2.5.4
Ant:          Apache Ant(TM) version 1.9.14 compiled on March 12 2019
JVM:          11.0.12 (Debian 11.0.12+7-post-Debian-2)
OS:           Linux 5.10.0-8-amd64 amd64
$ java --version
openjdk 11.0.12 2021-07-20
OpenJDK Runtime Environment (build 11.0.12+7-post-Debian-2)
OpenJDK 64-Bit Server VM (build 11.0.12+7-post-Debian-2, mixed mode, sharing)

Not being able to download avian is my fault, bintray has been shut down and I haven’t updated yet.
The visual artifacts are very odd, though, I am very tempted to say they are caused by the OS or a graphics driver, some buffer that isn’t properly cleaned.

The fact that it works on a linux laptop kinda confirms that as well.
If you say that the launcher has that issue, then every simple AWT Application has that as well. Based on that, you could try some more tests, try playing with JVM versions or your drivers and their control panel.

A good guess in such a situation would always be the iGPU/which GPU to pick, issues arising when moving between those, but if it works on a laptop but not on a desktop(?) then that’s not relevant.

Since you say that vanilla netbeans works, you can also try to get rid of the current theme (Look and Feel), since that uses some more special AWT Components that also triggered some OS specific bugs in the past.

1 Like

Thanks, I just tried to switch to windows classic theme, but it got bugged again… It mostly happens when opening lists(especially when they are empty, typing nonsense, asdf, and then pressing ctrl + space(to autocomplete) always triggers it)… very strange indeed…

can you think of any heavy awt applications, off the top of your head?(I’ll google tomorrow)

The netbeans runs with jdk 16.
I tried to run the jme SDK ide with jdk 16 as well, but I get these two errors

error one
Sep 21, 2021 1:00:01 AM org.netbeans.ProxyURLStreamHandlerFactory register
SEVERE: No way to find original stream handler for jar protocol
java.lang.reflect.InaccessibleObjectException: Unable to make field transient java.net.URLStreamHandler java.net.URL.handler accessible: module java.base does not "opens java.net" to unnamed module @7699a589
        at java.base/java.lang.reflect.AccessibleObject.checkCanSetAccessible(AccessibleObject.java:357)
        at java.base/java.lang.reflect.AccessibleObject.checkCanSetAccessible(AccessibleObject.java:297)
        at java.base/java.lang.reflect.Field.checkCanSetAccessible(Field.java:177)
        at java.base/java.lang.reflect.Field.setAccessible(Field.java:171)
        at org.netbeans.ProxyURLStreamHandlerFactory.register(ProxyURLStreamHandlerFactory.java:59)
        at org.netbeans.JarClassLoader.<clinit>(JarClassLoader.java:117)
        at org.netbeans.MainImpl.execute(MainImpl.java:153)
        at org.netbeans.MainImpl.main(MainImpl.java:60)
        at org.netbeans.Main.main(Main.java:58)
error two
java.lang.Error: factory already defined
        at java.base/java.net.URL.setURLStreamHandlerFactory(URL.java:1259)
        at org.eclipse.osgi.framework.internal.core.Framework.installURLStreamHandlerFactory(Framework.java:1765)
        at org.eclipse.osgi.framework.internal.core.Framework.<init>(Framework.java:232)
        at org.eclipse.osgi.framework.internal.core.EquinoxLauncher.internalInit(EquinoxLauncher.java:67)
        at org.eclipse.osgi.framework.internal.core.EquinoxLauncher.init(EquinoxLauncher.java:37)
        at org.eclipse.osgi.launch.Equinox.init(Equinox.java:178)
        at org.netbeans.modules.netbinox.Netbinox.init(Netbinox.java:63)
        at org.netbeans.core.netigso.Netigso.prepare(Netigso.java:145)
        at org.netbeans.NetigsoHandle.turnOn(NetigsoHandle.java:115)
        at org.netbeans.ModuleManager.enable(ModuleManager.java:1437)
        at org.netbeans.ModuleManager.enable(ModuleManager.java:1254)
        at org.netbeans.core.startup.ModuleList.installNew(ModuleList.java:315)
        at org.netbeans.core.startup.ModuleList.trigger(ModuleList.java:251)
        at org.netbeans.core.startup.ModuleSystem.restore(ModuleSystem.java:298)
        at org.netbeans.core.startup.Main.getModuleSystem(Main.java:156)
        at org.netbeans.core.startup.Main.getModuleSystem(Main.java:125)
        at org.netbeans.core.startup.Main.start(Main.java:282)
        at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:98)
        at java.base/java.lang.Thread.run(Thread.java:831)

so I’ll try to figure those two out tomorrow… probably just needs a lower jdk version…
I can also try using the jdk from the oracle’s site.

It is a very old gpu with legacy drivers. The driver itself does crash when alt + tab from AAA game, but works flawlessly in windows, well, until now xD

I’ll try other awt applications to rule that out.

no, only one gpu. this cpu doesn’t come with a gpu.
On the laptop, it’s using the integrated intel’s gpu.

I’m aware that this is most likely an error with my setup.
Gonna try to boot a live linux iso tomorrow, and see if it behaves differently in there.
Thanks for the help, btw :slight_smile:

The artifacts are common in Java Swing applications with some combinations of OSs and display drivers. That is very unfortunate. In my experience, in Linux these artifacts wont appear. But Windows + NVIDIA combo is a sure way to eventually see them. You of course have AMD, but it seems they have joined the party as well.

And these are very tricky to track. I didn’t used to have them in older SDKs. I have them only on the newest, 3.3 NB 12. NB 12 itself does work. It is some yet unidentified combo of things.

There are some remedies, I haven’t tried though… Like disabling the hardware acceleration from the process. I guess for the IDE/SDK this might be ok… But maybe not for the 3D app you are creating. But your app is simpler anyway. The only Swing part there is that of jMEs dialog if you have left it enabled.

1 Like

I found out that riva tuner statistics server was causing the issue :slight_smile:

3 Likes

That also caused game crashes (non jme) for me back then!
Since then I have downgraded MSI Afterburner and never upgraded anymore :smiley:

1 Like

Can we mark this issue “SOLVED” then?

Hello, just created an account to post this same issue, new to JME and fresh install and first time using on win11 w/amd video card as well. Netbeans 12.6 works fine for me.

It is pretty easy to trigger this consistently within about 30 seconds or so by mousing through the menubar options or scrolling in the text editor. I spent some time disabling plugins one by one and determined that disabling SDK Core prevents the errors.

2 Likes

To add a little more info, I did download the v3.2.4-stable-sdk1 release for win64 and it didn’t have any issues.

2 Likes