Step 6 of Getting started guide - testing JME

I ran the command as specified in the getting started guide, the command line replies to me with a help reply. Listing usage and options toward the java command. I do have it typed correctly as i copied and pasted it from the page.

Could you please paste the error message? You might be missing some quotes around your class' path if it contains spaces, or maybe you are in the wrong directory when issuing "java WhatEverClassYouWantToRun"…

Heres the code i pasted in: java -Djava.library.path=./lib -cp ./lib/lwjgl.jar;./lib/jogg-0.0.5.jar;./lib/jorbis-0.0.12.jar;./target/jme.jar;./target/jme-effects.jar;./target/jme-model.jar;./target/jme-sound.jar;./target/jme-terrain.jar;./target/jmetest.jar;./target/jmetest-data.jar

Here's the return value I get.

Usage: java [-options] class [args…]

                (to execute class)

      or  java [-options] -jar jarfile [args…]

                (to execute a jar file)

where options include: (then it continues to list all the options)

You're missing the class to execute after the call…

Yeah, I found the completed command near the bottom of the guide. I tried that, I am now getting this: Exception in thread "main" java.lang.NoClassDefFoundError: jmetest/effects/TestLensFlare I know I can compile java in this directory (C:Program FilesJME) because I did a simple helloWorld test to confirm.

some things were/are outdated in the wiki, for example the jme-sound was replaced by jme-audio and jogg-0.0.5.jar jorbis-0.0.12.jar are replaced by versions 0.0.7 and 0.0.15.

And there are now a few more jmetest jars

Make sure you actually have all the jars you list in your command.

i am updating the wiki right now.

The correct command line would be:

java -Djava.library.path=./lib -cp ./lib/lwjgl.jar;./lib/jogg-0.0.7.jar;./lib/jorbis-0.0.15.jar;./target/jme.jar;./target/jme-awt.jar;./target/jme-effects.jar;./target/jme-model.jar;./target/jme-audio.jar;./target/jme-terrain.jar;./target/jmetest.jar;./target/jmetest-data-model.jar;./target/jmetest-data-images.jar;./target/jmetest-data-skybox1.jar;./target/jmetest-data-sound.jar;./target/jmetest-data-texture.jar jmetest.effects.TestDynamicSmoker

Or for if you have java 6 you can use a wildcard

java -Djava.library.path=./lib -cp ./lib/*;./target/* jmetest.effects.TestDynamicSmoker

I tried your code, but no luck, same error. I did type it out as well to double check, and no luck.

are you in the correct folder when you execute the command?

if you are in the wrong folder you will get the "java.lang.NoClassDefFoundError: jmetest/effects/TestDynamicSmoker" error.

What you should do is post the whole command and its full output so we can help you further. (And an output of the lib directory would also help)

heres the code I use. java -Djava.library.path=./lib -cp ./lib/lwjgl.jar;./lib/jogg-0.0.7.jar;./lib/jorbis-0.0.15.jar;./target/jme.jar;./target/jme-awt.jar;./target/jme-effects.jar;./target/jme-model.jar;./target/jme-audio.jar;./target/jme-terrain.jar;./target/jmetest.jar;./target/jmetest-data-model.jar;./target/jmetest-data-images.jar;./target/jmetest-data-skybox1.jar;./target/jmetest-data-sound.jar;./target/jmetest-data-texture.jar jmetest.effects.TestDynamicSmoker and the output is exactly as Core-Dump said.

Maybe  java  does not understand the . (dot) operator and you have to put the whole path to the JARs in it, but that should not be an issue.

Backslash vs Forwardslash??

Linux and Mac: use /

Windows: use

ah yes my command is for a windows environment.

What OS are you using ?

As basixs said, you need to use forward slash and colon ':' instead of semicolon ';' in linux.

If it still dosen't work, check if you really have all the needed jars/dll in the lib and target folder.

Or use Eclipse :slight_smile:

I am using windows, yeah I saw that the wiki said its based on windows environment. I'll double check all the target folders when I get home.