Terrain editor problems

I was trying to learn how to use the terrain editor but I keep running into trouble. I created a flat heightmap using the default settings but the raise and lower brush did not seem to work, nor did the green wireframe “brush” track properly. It seemed to hover above the heightmap and it would “stick” at certain points instead of moving freely. I then tried a 512 x 512 image based heightmap and although it loaded just fine I still could not use the brushes and JME crashed when I tried to generate the LOD. Is anyone else having problems like these?



Do you have the latest version from SVN? I’ve recently fixed a lot of issues this last week, and they have not made it into an official release yet.

I did not use SVN, I grabbed the installer off the download link. I did check for up dates as of yesterday and it said I was current. I checked again just now and it has added a few more things.Let me try again and see what happens.



The recent updates seem to have helped a lot! I was able to edit the heightmap and also create the LODs. Thanks! :slight_smile: