The area of the app is just blinking and the disappears


Yes, I’m a totally new to both java and jmonkey, but I want to learn :slight_smile:

So, I downloaded the SDK and installed it without any error messages, then I went ahead with the very first example and followed it totally. When I tried to run it the black window was shown, I let the default setting be and thought that the example would be run in the window. But it was not, the window just staid black for a second and then it did close, nothing was happening.

What can I have done wrong?

Are you new to programming in general too?

Be aware that 3d games programming is one of the hardest areas of programming so trying to learn programming, a new language, and 3d programming all at once is going to be hard.

Also, which tutorial were you trying to run?

no, I’m not new to programming, but to java, I was mostly searching for a “lazy” fix for my IDE problem, anyway, I reinstalled it so now it works. :slight_smile:

Ok. A handy tip is that if you do new project JME3 Tests it will create a test project with all the ones from the tutorials and a lot more as well inside it.

Game development in general isn’t something you can just do “like that”, so much info you need to know about to not waste your time. Our documentation is meant to give an overview no matter how adept you might be in programming in that case some parts will just be quicker to read. So. Do yourself (and us) a favor and do read the manual. It for example also explains where you see the output of the application and how you can read error messages which are mostly very clear in describing what went wrong.