The JDK is missing and is required to run some NetBeans modules. I'v done.. EVERYTHING! -.-

I get this shit all the time!

I’v downloaded java 7 and netbeans 7.1 and tried to make it work. It didnt.

I uninstalled the whole shit multiple times and installed

java sdk 6.9.1 with netbeans 6 and I even checked the confg file in netbeans, Its in the correct path!!

I have no clue why this shit is bugging me!!!

Heeelp!! I’m dyying!

are you running under Windows or Linux? I had a similar issue under ubuntu 11.10. I fixed this by running jmp as root user. (Not the best of all solutions, but worked for me).

Its not the correct path if it complains like this. Maybe you set the install dir (like Programs/Java) that would be wrong.

Even in the jmonkeyplatform.confg it says:

...overridden by using --jdkhome switch
#jdkhome="C:/Program Files/Java/jdk1.6.0_30"

# clusters' paths separated by path...

#jdkhome” means it’s commented out. Remove the “#”. Or maybe the environment variable JAVA_HOME or JDK_HOME points to a different path. Open a command line prompt (cmd.exe) and type “set JAVA_HOME” and “set JDK_HOME” to check them. You could also check the JRE settings in the Java Control Panel.

This is an old topic - but it still occurs when installing jdk on Mac OS X 10.11 (El Capitan).

It may be because I inadvertently installed the jre prior to installing the jdk.
I uninstalled the jre, installed the jdk and reinstalled NetBeans but the problem remained.
However, the fix was fairly simple.

  1. Make sure NetBeans in not running.

  2. Make sure the jdk is installed.

  3. Determine the location of the jdk:
    The jdk location can be determined by entering the following (in Terminal):
    $ /usr/libexec/java_home
    For my system, the output was:

  4. Edit the NetBeans configuration file to indicate the location of the jdk.
    Near the bottom of this Netbeans configuration file (or equivalent for your NetBeans version):
    Comment out the following line (insert a # before the first character):
    Then, add the following line (or equivalent for your jdk version):
    Then, save and exit the editor.

  5. Start NetBeans (no more popup window indicating that the jdk is missing).