Thrustmaster Flight Hotas X

I have this wonderful joystick here and i would love to use it, steering my own game, but it won’t find any controller in the joystick test.
Is there anything i can do about making it work ?

This java test is working.

Now i have to try to find out, what differs and if i could make it work.
No one here ever used a flightstick ?

Is the version of jinput the same?

I once played around with game pads, joysticks, steering wheels, and even my drawing tablet - all worked well with the jme test project.

Two things almost always were needed:

  • plug in the device before you start the test project
  • install the official driver for windows (many gamepads and joysticks were not found until after the correct driver was installed)

I am curious too, what the version of jme is and who maintains the current version (it has been pspeed in the past). There were some hickups with the rumble function which did not work correctly, but anything else worked quite good. I will definitely return to input devices too in a few days or weeks. :chimpanzee_smile:

EDIT: maybe you need to restart the SDK too, so that all drivers will be loaded correctly (“have you tried turning it on and off again?”) :chimpanzee_wink: .

Information: Audio max auxilary sends: 4
Sep 28, 2015 4:34:30 AM handleError
Schwerwiegend: Uncaught exception thrown in Thread[LWJGL Renderer Thread,6,main]
java.lang.IllegalStateException: Cannot find any joysticks!
at jme3test.input.TestJoystick.simpleInitApp(
at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(

This is what i get. I haven’t changed anything. Just clean installed jmonkeyengine, updated it and started the jmetests.
The driver is installed and is working. I can also use the original JInput Samples from the internet. But i cannot start the joystick test in jme.

he says: Cannot find any joystick !

Ah, a German user, guten Tag. :chimpanzee_wink:
Did you try to reboot too?
Did you try a different gamepad and it worked?
Do you have the opportunity to test it on a different computer?
Maybe you can show the booting text of the SDK too?
Which version of the SDK - 3.0 or 3.1 ?
Which operating system? Is it up-to-date?

I’ve tested around 30 gaming devices (each under 40 Euro / 50 Dollars) on two machines and all worked - but for one device I had to uninstall a driver made for an other device from the same manufacturer (which was quite strange - I was only able to get either their joystick or their gamepad to work with jME - not both at the same time).

I will probably not be able to help you even if we try everything…