Trouble building module from command line

So I am trying to set up jenkins/hudson to build my little plugin-module. Since I like to use an updated platform to build I thought I’d build the SDK first and then build my module against the freshly built SDK.

But I hit a dead end, hope someone can share how they build things.

When I get the SDK from SVN I build with ‘ant update-platform build’ and this passes. When I try to build my module by using ‘ant -Dharness.dir=/[snip]/jenkins/workspace/jMonkeyEngine3/netbeans/harness nbm’ I get this error:

Unknown platform name ‘jMonkeyEngine_SDK_3.0beta’.

At my developer machine (another machine) when I build my module from the command line I see that it uses harness.dir=/[snip]/jmonkeyplatform/extra

Can this be the cause of it?

When I build the SDK the extra-directory has no build.xml in it so maybe I do not manage to build the SDK correctly?

I also tried to build against an installed SDK not built from source but that doesn’t have a build.xml in the extra-directory either. This SDK is a few weeks old since I don’t know how to update it from the command line.

I’ve looked all over and these forums but I’ve not been able to crack this nut, links or pointers are appreciated.


You have to build the project in trunk first, the folder above the SDK and engine folders. It builds both the engine and sdk and prepares all needed settings.

@normen said:
You have to build the project in trunk first, the folder above the SDK and engine folders. It builds both the engine and sdk and prepares all needed settings.

Yes, my bad wording, I do build the project in trunk, topmost build.xml. Don't know what you call the entire project - the whole shebang :)

I tried 'ant zip' to create the whole thing, thinking I could just unpack it and build against that but I get:

[snip]/jMonkeyEngine3/build.xml:39: Warning: Could not find file [snip]/jMonkeyEngine3/sdk/dist/${}.zip to copy.

Uhm, no idea. I can build it on windows and osx…? It looks like it doesn’t even have the properties file loaded?

just to be sure:


svn co http s:// jme3-svn

cd jme3-svn

ant run


…doesn’t download the netbeans base, compile the engine, copy it over, compile the SDK and then start the SDK for you?

Also btw, the contributions lib are compiled every night from the current svn… You just need to commit them to the project and I’ll update the suite properties file to include the module…

That at least finished with a ‘successful’ although headless linux server had some problems running the SDK :slight_smile:

Maybe it is just that I don’t know what to look for, ‘run’, ‘zip’ and ‘build’ all succeed in compiling the SDK. But I don’t know what to set as harness directory when I build my module. I thought (but I might be totally confused) that I either should set the jme3-svn/netbeans/harness or the ‘extra’ directory in jmonkeyplatform.

When I use jme3-svn/netbeans/harness I get the Unknown platform name ‘jMonkeyEngine_SDK_3.0beta’ when building the module.

I can’t find any ‘extra’ directory after building jmonkeyengine. I can’t find any zip-file to unpack either

ls engine/dist/

javadoc jMonkeyEngine3.jar lib opt README.TXT

I’ll maybe take you up on the contributions lib when I have something worth contributing. I’ll drop this jenkins-thingy for now and keep building from the SDK instead.

Thanks for your time.

So if you say specifying the harness manually through the platform properties of the suite (not through some config file) doesn’t work? I guess you have to make the platform base inside the netbeans directory known to the SDK then… So “Tools->Platforms” then add the platform. I wonder what went wrong that the SDK has no harness folder generally though…

I’m getting a bit closer. I noticed that when I installed the plugin “Netbeans plugin development” in jME SDK the build harness files were installed in the platform/extra directory (not as NB usually does it into a ‘harness’) directory, if I do not install that plugin there simply is no build harness that I could find.

Next step will be to try to use the ‘extra’ directory as a harness and see if that works. However, this is a bit inconvenient since what I’d really like is to be able to download the entire SDK or build from source purely from command line. My build machine doesn’t even have X windows so it is a bit hard to start the platform and select Tools->Platform :slight_smile:

Yeah normally it should just work by installing the mentioned plugins, the SDK should then use “itself” as the default platform with all shebang.