Trouble using sound

When i try the pong game from jmetest there is no sound during game and the tutorial intersection it not working eather because of a restructuring of the sound system.

Should I use sound from sun's jre or use the jmex stuff and is there maybe a howto for it?

There has been no restructering. It still works here too…

Try the OpenAL installer: and see if it works afterwards.

The HelloIntersection tutorial is still working ???

With me it is (the CVS version).

I also got the cvs version but there is no ProgrammableSound.class, SoundAPIController, Soundpool and AbstractInputAction.

Check out the HelloIntersection class in cvs in the package jmetest.TutorialGuide.  It is updated to work with the latest jME.

Sorry for that I should have lokked closer.

Thanks for pointing me towards it. :slight_smile:

I wish you all a nice weekend.

regards Sue

Ok problem is solved but ina strange way.

I copied the from "Bang! Howdy" so my jME/lib folder an replaced the existing one and now I am able to hear the sound.

Can it be that there is a problem with the libopenal from cvs?

I cannot answer your question but it would explain some trouble I have with sound and jME on Linux.

You may have seen it. There is a nice and easy SoundNode here:

The libs in jME (and LWJGL) are indeed pretty old compared to the ones on I don't know why, newer libs seem to work well if you replace the old one with them. The issue's been raised before but never really solved.