UnsupportedClassVersionError from jME3_SDK_Alpha-3-windows.exe

From the log:

[2010-11-30 22:56:07.979]: java.lang.UnsupportedClassVersionError: Bad version number in .class file

[2010-11-30 22:56:07.979]: at java.lang.ClassLoader.defineClass1(Native Method)

[2010-11-30 22:56:07.979]: at java.lang.ClassLoader.defineClass(ClassLoader.java:621)

[2010-11-30 22:56:07.979]: at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)

I know this is because it must be attempting to run this with an older version of Java. I have at 4 versions of Java installed (1.5 x86, 1.5 x64, 1.6 x86 and 1.6 x64).

I’m assuming I need to make the installer use the Java 1.6 version? How do I do that? I tried setting my JAVA_HOME to the 1.6, but that didn’t help.

I’m sorry I can’t be of more help but I just have to ask: Why do you have 4 different versions of Java installed ?:?

You can set the path to the JDK you wanna use in etc/jmonkeyplatform.conf

1 Like

I have 4 versions of Java installed because I develop a swing-based application that needs to be tested on each of these versions.

Where is this etc/jmonkeyplatform.conf file? All I have right now is the jME3_SDK_Alpha-3-windows.exe.

I ended up figuring this out. When I said I tried changing my JAVA_HOME, I only changed it in the command shell and then ran the .exe. It occurred to me that the installer may not be using the environment from the shell that launched it, so I changed my JAVA_HOME in System Properties and that ended up being the solution.

Thank you normen and erlend_sh for your responses.