Updating SDK and Installing plugins not working (Linux x64) [SOLVED]

I’m running 3.0 stable, on Ubuntu Linux x64 (version 14.04).

Whenever I update the SDK, it restarts and then I’m back at the version of was at. (It asks me to update again), no errors though.

When I try to install a plugin, I get this:

The Plugin Installer found problem timeout of loading Projective Texture Mapping[com.jme3.ext.projectivetexturemapping/] while install the following plugins:

Projective Texture Mapping

I looked at some similar topics on the forum and ran

chmod +x jdk/bin/*

in the jmonkeyplatform directory, to no avail.

Maybe you started the SDK as root the first time and now your settings folder is owned by root?

Hm. Doubt that. I can check though…

Nope, both the ~/.jmonkeyplatform config dir and the application itself (in ~/Apps/jmonkeyplatform) is owned by me.

Ah and you’re supposed to chmod the jdk bins, not the jre bins

Oh and wait, its a download issue, maybe check your internet connection / firewall etc.

When installing a plugin, It says it downloads the package (and extracts it too) it only fails when installing.

Thats not the error message you posted though…

…ok, let me try to install a plugin now.

Oh and, I ran chmod +x jdk/bin/*.

So, it seems to be downloading the plugin as far as I can tell, then validates it and says “the following plugins are not signed”. I click Continue and then it begins to “installing plugin” and shows a slider.

Ah, there we go. Solved it.

This command, solved the issue: