Urgent problem "org.lwjgl.LWJGLException: Pixel format not accelerated"

Hello all,

I have a project here displaying an applet. On my system everything works fine, but on systems of my partners and customers they get exceptions:

Verwendung der JRE-Version 1.6.0_07 Java HotSpot(TM) Client VM
Home-Verzeichnis des Benutzers = C:Dokumente und EinstellungenAndreas Born

c:   Konsole l

things to check:

  • does the provided lwjgl applet (appletloader.html) run on that machine ?
  • do other lwjgl/jme demos work ? (http://lwjgl.org/demos.php)

Its probably because 800x480 is not a standard format, and therefore unsupported by some cards. Can you use another resolution?


please remeber - we are using applets here - and these are NOT bound to any screen resolution … afaik

but - I asked the lwjgl community and THEY HAVE A SOLUTION:

catch (LWJGLException e)
            // failed to create Display, apply workaround (sleep for 1 second) and try again

edit: They told me that this code snippet works only for applets not for normal apps ..

can someone tell me where to apply this code ?


The Applets display is created in BaseApplet around line 122


Can someone tell me please what file and howto export the file (onto a webserver) which contains my changes ?

Changes are in (com.jmex.awt.applet: BaseApplet.java)

Do I need to sign it or something like that?

Thanks in advance!


after making changes to BaseApplet, you have to recreate the jme-awt.jar.

In eclipse right click build.xml -> 'run as …' and choose dist-all.

This will create the jars in the /target directory.

Then just sign the newly created jme-awt.jar and replace the old one in your applet with this one.

(might be a good idea to sign and replace all jme*.jars)

Thank you,

ok - now i'm able to produce the jar's, sign them and copy them to the final location.

The bad news is: the workaround didn't work :frowning:

Well, investigating it, the function

Display.create is called with a newly generated pixelFormat class with parameter

bpp=0, alphaBits=0, stencilBits=2, samples=1

Is this a correct parameterization?



Not sure if you solved your problem yet.

On my machine I had the error and I fixed it by downloading and installing new graphic drivers.