VSync doesn't work


I created a new project. It is totally empty. When I start the game, the settings screen appears. There I can enable/disable VSync. But for me VSync doesn’t work when I check the box. I got around 1.600 FPS.

I use the latest release “3.1-beta1-b002-SNAPSHOT”.

Does the same happen for you?


Even if you use settings.setVSync(true); ?


Do you happen to have a 1600Hz screen?

Jokes aside, what’s your screen setting? Also graphic card drivers up to date?

1 Like

Thanks for your reply!

My screen resolution is 1920x1080. I will try to update my graphic card driver, even though I already have a quite new one.

I was more thinking about the refresh rate. if you have faulty drivers maybe the refresh rate is not properly detected…idk…

60Hz Monitor. In the settings 60Hz is selected as well.

Probably not related. But on my linux box vsync just doesn’t work. I always get screen tearing etc. However i also know this isn’t jME. Its a xorg issue with my muiltimontor setup and odd mode lines i use.

When i am single screen i can force it with a manual modeline. Clearly however this is specific linux setup issue.

Hmm … I updated my graphic card driver and even reinstalled the SDK. But VSync is still not working. What could be wrong with my system? I assume VSync is working for you guys, right?

On my Intel driver it is fixed at 60 fps no matter if i disable or enable it but on my AMD card yes it works.
For me full-screen mode not works when i connect a monitor to my laptop :wink:

Hmm, now that you mention it… my laptop wouldn’t use vsync either when I was working on it yesterday, but I wrote it off as just me probably setting it to false somewhere in code (i didn’t) and didn’t think much of it at the time.

GTX960M, 3.1 beta-1