Web Start launch solved


I clean and build a ‘local’ version of a Web Start deployment. All files and lib areas are created well. I use the local command line path displayed in the output of the clean and build process to test the file. The file loads and displays the jMonkey Engine splash screen with screen adjustment settings fine in command line (DOS) and allows me to select screen adjustments, but when I agree to launch the project on the splash screen the splash screen is no longer displayed and the project is never displayed. After I click the splash screen I do not see any other screens ever displayed. The project works fine in a default run in jMonkeyEngine IDE. What am I missing?

Thanks for the help

Check the java console

Hey normen,

Thanks for the reply.

The *.jnlp file is not written out correctly. Any suggestion to get the build to write the *.jnlp file out with the correct syntax?



If anyone is interested I had to clear the WebStart cache with: javaws -uninstall

I could then see the edits to the *.jnlp file necessary to allow complete parsing of the file.

and so which edits are these?


The original *.jnlp contains the line:


<application-desc main-class="mygame.Main">




I had more luck launching the WebStart when the *.jnlp file containned the line:

[xml]<application-desc main-class="mygame.Main" />[/xml]

My reference was JNLP File Syntax @ http://download.oracle.com/javase/6/docs/technotes/guides/javaws/developersguide/syntax.html

Thanks for the help.

1 Like

That is kind of strange as the upper version is valid xml too but thanks for the hint!

Agreed, All the XML tools I tried would report the XML as valid code with proper syntax, but when I would run the launch.jnlp file the console would report a parse issue at the [xml]application-desc[/xml] line in the code.