Weird mesh.xml bug while loading and Blender plane.001 error

I have been trying to import new character in my game since a while now, but it simply fail everytime, no matter how i try. This is the linik

First, i decide to go whit the .obj extension and it worked great but as i learn later, this format does not support the animation. So i decided to try the mesh.xml format inside of the file, but I always get this error message

Grave: Uncaught exception thrown in Thread[LWJGL Renderer Thread,5,main]
java.lang.ArrayIndexOutOfBoundsException: 1
    at com.jme3.scene.plugins.ogre.MaterialLoader.load(
    at com.jme3.scene.plugins.ogre.MaterialLoader.load(

and so on. The specific methode that crash is this one :

String[] split = statement.getLine().split(" ", 2);
            matName = split[1].trim(); // this line
            Material mat = compileMaterial();
            list.put(matName, mat);

I might be missing something very trivial but its realy kinda annoying. Plus, when i try to export something from blender whit the ogre exporter, one of two things happen. It either just give me a plane.001.mesh.xml that don’t work or the exportation actully work yet when i try to load it in game… i got things like this :

Grave: Uncaught exception thrown in Thread[LWJGL Renderer Thread,5,main]
com.jme3.asset.AssetLoadException: An exception has occured while loading asset: Models/Bug/robot_bug.mesh.xml
    at com.jme3.asset.DesktopAssetManager.loadAsset(
    at com.jme3.asset.DesktopAssetManager.loadModel(
    at com.jme3.asset.DesktopAssetManager.loadModel(

And this goes here

 try {
            obj = loader.load(info);
        } catch (IOException ex) {
            throw new AssetLoadException("An exception has occured while loading asset: " + key, ex); // the bugging one
        } finally {

I am doing something wrong for sure but what? Any suggestion? Or any ways i could find some animated assets somewhere that won’t crash so I can finaly do my test? I already use the the ninja and oto one, but I would like to try more.

What if you import the blend file directly?

It depend of what i try to import, but it either give it no color and animation, or a serie of error saying :
Constraint named: ‘Copy Transforms’ of type ‘Trans like’ is not implemented and will NOT be applied!
Making me assume blender is suppose to support that part.

Edit : and on some rare case, JME simply froze and the CPU goes crasy… once it decide to it 100% of it capasity. Maybie because i have play whit some settings i should not play whit but ya… am not lucky so far whit the 3D importation

ReEdit : make it twice for the crasy 100% cpu part.

Well it looks like the file itself is kinda bad, I couldn’t import it in Blender using fbx or Collada, so I guess the mesh.xml is also not working.

Fair enouf, the file was new and might be corrumpt or something. But then could you try one of theise?

I tried all of them… more then once, in more then one way, and yet nothing seem to work. Maybie my blender file is broken or something, or maybie as i said am just missing something very simple but those are all blender file, so they should work right?

No, the fact that its a blender file doesn’t mean at all that its a game compatible model.

I could at least get the first one into the engine (I haven’t tried the others) using OGRE although the animation is kinda messed up. But as normen said, a lot of these files are not game compatible and you’ll have to manually edit them to use them.