Wrong scale with MaxToJme


I try to load a 3DS Max 7 model exported to 3DS into a SimpleGame. Some parts are way too small, others are too big. The positions seem to be correct. I used the HelloModelLoading.java and changed it to use MaxToJme. Another try with the model converted to jme format by the main function in MaxToJme shows the same effect.

Is 3D Studio Max version 7 exporting a 3ds that jME does not read correctly?

Oh and I had the same problem as reported here before with the index exception and could fix that by making sure the textures are squares.

The problems never end. I'm still looking for a way to create a scene and load it into jME.

What I tried so far:

3DS : objects are scaled differently, some are way too big, some are too small.

3DS to Milkshape to jME : the scene must be rotated, the lights are lost

3DS ASCII to Milkshape to jME : the lights are lost

Wavefront OBJ to Milkshape to jME : the lights are lost

Wavefront OBJ to jME : there are lights but all materials lost

For sure there is a way to get a good looking scene into jME but how?

I'm stuck …

For the scene I used the export to 3DS from Max3D, then MilkShape to save and the nMilkToJme. This worked more or less.

Now I try to get a character model into the scene which is constructed in Max3D with bones and IK chains. The .3ds format does not work (scale is only for single objects not for the whole model, so it looks like small object spread around) and in milkshape you can see all bones.

How do you create and load models into jME ?

So, you have a model that has different scale levels, and we only apply one to the whole model?

And the bones are visible in Milkshape?

Can you post your 3D model anywhere? We'll look into it ASAP.

The model is http://www.world-of-mystery.de/download/wizard05.max (don't laugh, I'm really not an artist :slight_smile: )

The current source and binary is there as well, look for wom.zip and womsrc.zip.

I try to put basics in place, I hope I can find some artists later.

I can't give advice on the scene but for the character models 3ds does not support skeletal animation at all it only does translation rotation and scale I heard you can build morph animations with them but its long process

if u have milkshape use that for charcters or blender there are scripts around for it you also export to md5 but that doesn't compress to .jme… yet , you can also do motion blending if you choose to go the md5 root for now see usercode forum

Is there an exporter to .md5 for max3d? I found one for md3 but it complains about missing shaders and the number of objects exceeds a limit of 32.

as of today if you updated jme the md5 code would be broken sorry I'll try to fix it but I I'm not the best coder as for exporters doom3world.org has export scripts for blender and 3dsmax, as I said if you have milkshape use that only all this stuff is sorted out

I got the same problem with the scale of the 3ds models.

Models which have the same size in the modeler have a totaly different, when i load them with jme.

I am going to be helping out with the animation system and the model loaders.  Mark is having me look specifically at your scaling problems.  If you guys could give me as much information as possible it would help (screenshots of what the model should look like, the model, etc.).  We are looking at expanding the capabilities of the animation system.

Hondo said:

If you guys could give me as much information as possible it would help (screenshots of what the model should look like, the model, etc.).

See http://www.world-of-mystery.de/download/ for the data and http://cvs.world-of-mystery.de/cgi-bin/cvsweb.cgi/wom/ for the source code. To run the client you would need a patched l2j server so it might be easier to load the model into a sample program.


I tried to load a model in a separate thread so that the main thread handling the user events and update continues fluently.

The thread is started where I used to load the model and just for the test the main thread is waiting (Thread.sleep).

The thread reading the model is stopped with an access violation exception in the VM:


The source is here:


Is there a problem with the DisplaySystem when using two threads?

OpenGL is single threaded only.  So anything that touches the display in any way must all be in the same thread.

You are right. I changed the Thread to a normal class and the model loading works.

Too bad that the model loading is already needing the DisplaySystem. Could that be separated so that e.g. only some functions have to be called in the displaying thread but the main part could be separated? It's only the loading into the nodes, I won't update the display in the second thread.

I would like to load scene models on the fly but having to wait until it's finished causes a break in the game which is a bad thing in a MMOG.

It's certainly something we are shooting for.  Are you using the CVS version?  If so, past the initial screen display it should be able to load models on another thread.  At least in theory.

We fear theory…we are programmers, we bring theory into our own world of reality. :slight_smile:


So, let's go into practice :slight_smile:

I load an initial scene in the initGame function and later on one in the update function. The first one loads ok, but in the second one the texture is missing. There are no exceptions.

For the second one I just use a copy of the first so there is no problem in the scene itself.

Maybe there is a problem with loading a texture twice?

I'm using the latest CVS version.

The used source is (as always :slight_smile: ) here: http://cvs.world-of-mystery.de/cgi-bin/cvsweb.cgi/wom/

I come back to the model loading problem as I still have no clue how to load a scene into jME so that it looks at least similar to what I did in the modeller.

How do you do that?

This is the model in Max3D and a rendered part

with texture and materials

and this is after converting to .jme


This was with:

  • Max3d export to .obj and .mtl
  • convert into .jme with ObjToJme

    Next try with:
  • Max3d export to.3DS
  • convert into .jme with MaxToJme

    The texture is there but the texture coordinates are lost. It should be face mapped not spread over the whole mesh. The material settings are lost.


Next try:

  • Max3d export to ASE
  • convert to .jme with AseToJme

    The geometry is wrong for the two planes - they should be parallel. The scene itself is displaced as well.