Animation problems

I have a similar problem: Blender to ogre convert error

I Apply all parameters. And have problem with animation:
When i click on the animation.

Maybe you have something wrong in Blender’s settings. @winhelp should know something about it.

What should be the blender settings? What could be wrong?

I don’t know, that’s why I’m calling for my teammate. He is an expert, he is working with Blender and JME.
All I know is that you need to set up few things in Blender.

You need to apply the objects transform. Select your model in object mode und click on “Object” and apply location, rotation and scale.

i apply

Please check model file
https://drive.google.com/file/d/0B-zv3i43GFAhc1RfOWlNX2lqaXc/view?usp=sharing

Did you also apply transforms to the rig?

The image you provide shows the mesh.

Edit: You are supposed to apply transforms prior to parenting mesh to rig, prior to animating.

I tested your model, with directly converting .blend file to .j3o (right click on .blend file and chose convert to j3o binary) in SDK and animations are working OK.

Also are you using the latest version of JME SDK 3.1 ?

.blend to .j3o works well until you have hardware skinning disabled.

  1. I Update SDK to 3.1.0-SNAPSHOT.
  2. I Apply transforms in blender.

Model load good without Distortions.
When i convert blender to j3o. SDK say:

Loaded asset player_test
File player_test.blend saved successfully
Notified about change in AssetData properties for player_test
player_test listening for external changes on /home/nn/omonkeystrike/assets/Models/player_test.blend@b66943c0:1bb2f23
Set original path for player_test to Models/player_test.blend
Removing asset Models/player_test.blend, from cache via main asset player_test.
Removing asset Common/MatDefs/Light/Lighting.j3md, from cache via main asset player_test.
Removing asset Common/MatDefs/Misc/Unshaded.j3md, from cache via main asset player_test.
Loaded asset player_test
Running blender with options /home/nn/omonkeystrike/assets/Models/player_test.blend
connect failed: No such file or directory
Loading animations that will be later applied to scene features.
Found animation: automatic.
Found animation: direct-death.
Found animation: direct-half-left.
Found animation: direct-half-right.
Found animation: direct-left.
Found animation: direct-right.
Found animation: direct-sit.
Found animation: half-left-direct.
Found animation: half-left-left.
Found animation: half-right-direct.
Found animation: half-right.right.
Found animation: LampAction.
Found animation: left-direct.
Found animation: left-half-left.
Found animation: one-shot.
Found animation: right-direct.
Found animation: right-half-right.right.
Found animation: run.
Found animation: sit-death.
Found animation: sit-direct.
Found animation: sit-left.
Found animation: sit-right.
Found animation: sit-run.
Found animation: start.
Asset path “Models/…/…/…/…/…/…/textures/brown_eye.png” is outside assetmanager root
Asset path “Models/…/…/…/…/…/…/textures/brown_eye.png” is outside assetmanager root
Asset path “Models/…/…/…/…/…/…/textures/brown_eye.png” is outside assetmanager root
Asset path “Models/…/…/…/…/…/…/textures/brown_eye.png” is outside assetmanager root
Asset path “Models/…/…/…/…/…/…/textures/brown_eye.png” is outside assetmanager root
Loading model’s textures.
The texture Texture.001 has linear color space, but the material parameter DiffuseMap specifies no color space requirement, this may lead to unexpected behavior.
Check if the image was not set to another material parameter with a linear color space, or that you did not set the ColorSpace to Linear using texture.getImage.setColorSpace().
Loaded asset player_test

SKD find animations, but not load animcontrol.
I have 4 mesh objects and not have animcontrol
Animation found but model tree have this:

Maybe i have errors in blender file or settings again?
https://drive.google.com/open?id=0B-zv3i43GFAhU21hS2RwM3RaNGs

Took the old version of model. not apply scale.

I looked at your blend file and its full of errors. This is your problem.

Your actions have not been made into a NLA strip. That’s why no anim control.
Your material is not named after the model.
Your timeline is off by one.
Your model is poorly UV Mapped. As a result you have useless information in the UV Buffer and UV coordinates all over the place.

I have 2 suggestions.

  1. Go through these tutorials to learn all about Blender. https://vimeo.com/nhirsig/videos/sort:alphabetical/format:thumbnail

Although a little dated, the info is solid and will help you immensely. He has website also but it looks like it and he may no longer be with us unfortunately. He was early 60s when did these.

You can use http://www.cachedpages.com/ to view his cached site if you can tolerate the delays.
http://gryllus.net/Blender/PDFTutorials/AllPDFTutorials.html
2. Wait a day or 2 for the new tutorial I have been working on that explains how to rig models using Mixamo. Although its directed toward that end it does contain blender help on how to actually create NLA strips for JME3, the problem you are having right now.

I suggest you do 1 until then personally.

1 Like

Thanks. I remake model.

Also make sure when making keyframes, let only your rootnode contain position keyframes.
For the rest of the bones, do NOT keyframe position, only rotation, scale.

If not add key’s for all bones - model have basic position for bones for which not add keys.

i add two channel for play

1 channel: chest rotation
2 channel: leg run

if i not add to animations keys for hands - hand’s have basic position.

UP

Btw, does you model have Armature modifier in Blender? I checked your blend file and it did not.

To add armature modifier, first deparent the model, make them same scale, then select model and shift select armature, so that both are selected. Then press CTRL+P and set parent with automatic weights. Attempt to convert it after.