Best Linux for JME3

I’ve had a huge amount of trouble installing and running JMonkeyEngine. First I couldn’t get the JUnit package to install and load properly, so I uninstalled. Later I tried again and now the IDE crashes during launch.

I was using Kubuntu, but have since switched to Linux Mint, and I have Java 6, 7, and 8 (all official Oracle versions) installed. What I’m wondering is if some other version of Linux is better or more tested with the development kit. Does anyone know if there is a version where the installation and launch are known to work properly? If so I may try a virtual box or second partition.

(If this doesn’t work I may try Windows in the future, but can’t really afford it right this minute.)

I have no problems using the IDE on Fedora 21 on a Lenovo Thinkpad T520. After iinstalling using the installer there is a Java 1.7 JDK next to the IDE, so it shouldn’t matter which you installed locally. Maybe it is a hardware/driver problem. You definitely don’t need Windows.

I run on ArchLinux with oracle jdk 1.7 and 1.8. the only issue is to do some chmod +x on some */bin/ file (jmonlekeyplatform, the embded blender, …)

I can’t find anything that obviously needs to be made executable and isn’t already.

I’ve downloaded Fedora and may install that somewhere and give it a try. Be back when I see how it works out.

How are you trying to install jUnit library? I am no expert but I presume you can just add the jar file to the project library and use it from there.

I had some problem when I was trying to update jMP from nightly. I was using ubuntu. In my case the problem was the jMP executable and the adjacent folders didn’t had the permission to write the updated files in the correct location. I had to update the permission of the jMP files and folders.

Continuing the discussion from Best Linux for JME3:

JUnit is actually yesterday’s problem. The problem I have now is the development kit won’t even run. I crashes on start-up – long before JUnit becomes an issue.

I’ve tried installing Fedora to see if that works better but it can’t seem to partition the hard-drive, so I may just need to get a new drive (perhaps an SSD this time) and try that again.

I made a discovery – after reinstalling my whole OS JME installed and ran fine as well. However, after running once as root (to see if this might install the jUnit library, i.e., if it was trying to install somewhere in /usr instead of my home directory) it will now no longer launch at all.

Perhaps I’d done this before? I can’t remember, but it seems that if you make the mistake of launching even once as root non-root users cannot use it any more. Instead, it now crashes on launch again. My best guess is that some file its trying to load has been assigned to root, but using chown to fix this doesn’t work, so I have no idea where this might be.

This was the problem that was concerning me when I posted this – SDK crashing on launch. Does anyone have any ideas what might be happening / where I can find the file to fix this?

EDIT: I fixed with a shotgun approach using:

chown -R jared.jared j*
chown -R jared.jared .j*

…so, I think that was the problem all along before – something it required had been assigned to root, and the crash on start-up was occurring because it was unable to load that resource when run as a normal user.

Yep I had that same trouble (Ubuntu LTS) at first, just reinstalled it with the right mode.

Ahh, beautiful linux permissions :slight_smile: Can get messy if one doesn’t pay attention ^^

Btw in any linux distribution, never run a graphical application as root using “sudo”.
this executes the application as root and config files etc will be written to root, not your current user.

If you need to run graphical applications with root privelege “as your own user”, use “gksu” instead of sudo.

Though I do not know if this would have prevented this problem completely, as the IDE is not meant to be initialized with root priveleges

Any Linux distribution is good but the best is the one you like.

Just for some people who do not regularly use linux:
“Ubuntu” is the most popular and most supported distribution. (Steam supports Ubuntu officially)

The current version is Ubuntu 14.04 LTS, but Steam also supports the older 12.04 LTS.

The versions in between are basically “work in progress” and only supported for a short time.
You can read more about the support lifetime of the versions here: Releases - Ubuntu Wiki

I might warn that ubuntu has often very old versions of support software.
Eg gradle 1.8 ect.
This is usually not a real problem, but if you continously find yourself running into such problems a more uptodate linux distribution might be a good choice (fedora? debian unstable).

I myself use Arch Linux, and find it great, however I cannot recommend it for casual linux users. (If you want to learn more about linux its great however)

1 Like

May this can help you with that.

For old software versions you can always add a more updated specialized repository.

Well at one point working with bullet it had a problem in cmake (bug in old version for crosscompiling), unfortunately this was so deeply rooted into the system, that you had to replace most gcc related stuff (support libs, ect.) then :stuck_out_tongue: It was easier to start a vm with another distribution for me in that case XD

I would also recommend fedora and Debian. I think i would say Debian over fedora as fedora is on a 6month release cycle and has some issues with video drivers at the moment. From an user standpoint I feel debian has better/moreuptodate documentation but lacks in raid support.

Mint is based off ubuntu/debian & Ubuntu is based off debian. So debian would be more in line with your experience sofar. I currently use fedora 22 workstation with kde plasma desktop. Its a great experience but has its issues. Jmokney runs great I get about double the performance my windows box does even though i have worse hardware in my linux rig.

Linux rig
8g ram 1600
1tb seagate (it was cheap)
gtx 560 2gig(non ti)

windows rig
i-5 2500k
16g ram 1600
2x wd RE4 500g (raid 0)
gtx 680 4g (most powerful kelper gpu)