Black fog and texture resolution problem


I have a problem with black fog.

I create an array of boxs and for each box i wrote the flowing


float size = 0.5f;

Box b = new Box(“ground”+number , new Box(size,size/10,size));

mat = new Material(assetManager, “Common/MatDefs/Light/Lighting.j3md”);

mat.setTexture(“DiffuseMap”, assetManager.loadTexture(“Textures/desert250x250.jpg”)); // in the flowing images I changed only this line



// And I have a light

//(the problem is not from the lights because I tried it without lights by useing the “Common/MatDefs/Misc/Unshaded.j3md” same thing happens when applying textures)


This happens when using 250x250 jpg image.

This happens when using 50x50 jpg image. (there is still a black fog at the back)

This happens when removing the line //mat.setTexture(“DiffuseMap”, assetManager.loadTexture(“Textures/desert250x250.jpg”));

There is no fog here witch is what I want but no textures :frowning:

What I’m I doing wrong here I want to have high resolution textures but not the black fog.

Is there a way to do it? I’m using JmonkeyEngine 3.0 if this helps.

thanks in advance.

if you want, you can post the code for a simple testcase, and I’ll try it :slight_smile:

1 Like

try to use a DirectonnalLight instead of a PointLight.

1 Like

I tried to DirectonnalLight but same thing happens.

I posted a fully working demo on

tanks for the reply.

Make sure to set shininess, e.g. material.setFloat(“Shininess”, 16) or something other than zero. It is a known bug with NVIDIA shader compiler …

1 Like
Momoko_Fan said:
Make sure to set shininess, e.g. material.setShininess(16) or something other than zero. It is a known bug with NVIDIA shader compiler ...

But I can't find the material.setShininess(float) method
I checked :

yeah in fact it’s material.setFloat(“Shininess”,16);

1 Like
nehon said:
yeah in fact it's material.setFloat("Shininess",16);

I have set the shininess with material.setFloat("Shininess",16); , but still same problem :( THE BLACK FOG
is there a software render that I can test or some way to use Mesa3D software render instead of openGL.
if not I will fix this bug my self, it's hardware specific bug.
I have programmed with OpenGL and C before. Any I idea where to start looking for the bug!

I’ve try this on ATI mobility radeon X1800 and my friends ATI radeon X1900 same problem on both.

I have play many many many games on my computer and never seen a black fog in a game. It must be a bug flying around on ati video card. :smiley:

I will try it on more hardware soon …

I also tried this in eclipse and it works, but I gotta say that I forgot to Refresh project (F5 on project name) after I put that texture file (d250.jpg) using ie. explorer so I kept getting jme exceptions that’s not found…

Anyway, on ATI Radeon HD 4800 Series

Maybe you can try fiddling with some of the options for your drivers(in ATI catalyst or something), I know I had some issues because I didn’t have them options on default (like random culling of Arrows)