Blender 2.8+ for jmonkey

Why exactly does the jmonkey SDK ship with Blender 2.79 instead of a more up-to-date version? I’m looking at upgrading my blender version to 2.8 or 2.93 and wanted to know just in case 2.8+ isn’t as compatible with jme or necessary plugins.

JME works with newer Blender… assuming you are using GLTF as the format, anyway.

I’m currently using 2.92 without issue.

I did try updating to a newer version than that and then went back… but I don’t remember if that was a problem with compatibility in general or just things that happened to my models in the upgrade that I didn’t feel like dealing with at the time.


It’s simply because 2.79 is the last version that provided support for OpenGL 2.1 and which is still supported by old systems. Blender 2.8 requires a system with a high grade of OpenGL 3+…
I currently use Blender 2.49b:
blender (4) (1)
Because i love the straightforward simple interface despite it’s an old version, but starting from Blender 2.50 - 2.79 i don’t like the interface, but i love the welcoming Splash image of Blender 2.78:

And guess what!? The new interface of Blender 2.8+ is awesome which kinda looks like 2.49 but doesn’t works on my PC because my OpenGL is 2.1.

I think it’s more of a bottleneck situation;
Someone needs to manually update to a more recent version, and that means that someone needs to test that everything works as before.
ref: Blender 2.8 Support · Issue #222 · jMonkeyEngine/sdk · GitHub

I’m using gltf exported from Blender 3.1. Works :ok_hand:


@Kling thats not why as far as i know.

By this Blender version i understand .blend loader that IMO we should just get rid of since there are maintained export/import formats like GLTF/FBX/ogre/obj/etc.

.blend loader each new Blender version need update, and we have no manpower to update it each new Blender version.

Your argument with OpenGL 2.1 might be real, but i never heard of it as the reason for .blend to work for 2.79

my tip for every newcomer is: use GLTF and nothing else.


ofc using GLTF, you can use ANY Blender version that support it(as i remember 2.79 also had GLTF plugin, but needed download it, in 2.8+ it was already in Blender)

and if you are not artist, you can just download GLTF/FBX from


Yep, this is solely due to the legacy formats that worked with this particular Blender version.

GLTF is the new asset pipeline. And that works with wide variety of Blender versions.

In my opinion, the current SDK should not contain any Blender. It bloats the SDK size. And it is automatically outdated. SDK releases aren’t tied to Blender releases. User can choose whatever modeling software he/she pleases, and the version too.


Moreover, some prebuilt assets already come as GLTF and might not even need a modeling tool if one is in a hurry.

1 Like

Update: Downloaded Blender 2.93. Very slow for my poor computer, but yeah, works fine for jmonkey. I want to try 2.8 next.

Thanks y’all for your input. :slight_smile: :+1: