Blender 2.8!


#21

Hello @Ali_RS I have set the shading to look dev.
Here is a comparison of the same blend file opened in 2.79, and in 2.80

As you can see, the materials just show as a whiteish grey.


#22

I am not sure about 1.8 but if you use the animation layout, the graph editor is already setup in the lower left cornar. After you set one keyframe the button will appear that lets you toggle acitive keyframe.

edit: If you dont see the open panel, with mouse inside the graph editor toglle it open with the “N” key.


#23

i think you might get something wrong reading my posts, because i really dont know what you talk about :smiley:

i see graph editor. it was about interpolation change and gltf exporter. anyway its solved now.


#24

Maybe it’s because your model uses Blender 2.79 Internal rendering and material system. As far as I know blender internal rendering is removed in 2.8.


#25

Hmmm, not sure. The model was originally imported from fbx into blender 2.79, but I cannot get 2.80 to import the fbx files I use. It does crazy things to the bones (at least I think that is what it is breaking).

Is there any way to change the rendering and material system on a blend file to make it work? I am surprised that it does not fix this automagically.


#26

Do not know, Maybe you try to export your model to gltf in blender 2.79 then import it to blender 2.8.


#27

I tried that, but the issue is that the old glTF exporter does not export mesh morphs outside of animations. This was fixed in the new glTF-Blender-IO plugin. So if I export from 2.79 I will loose my mesh morphs.

I guess what I need is for the fbx support to get fixed so I can reimport into 2.80.


#28

Note, you can use glTF-Blender-IO in 2.79 too. Just download it from master (it’s about 25 MB)

then unzip it then go into this folder:

glTF-Blender-IO-master/addons/

inside it there is a folder named io_scene_gltf2, just zip it and install in in blender 2.79:
File -> User preference -> Add-ons -> Instal Addon From File


#29

I did not know that!
That will fix all my problems, thank you!


#30

You are welcome :slightly_smiling_face:


#31

btw, here is the manual :

https://docs.blender.org/manual/en/dev/addons/io_gltf2.html

It uses 2.8 but the same should be applicable in 2.79 too with this exception :


#32


#33

That scrip does not work as of yesterday with bone animations and gltf as of my trying it.

Maybe I am doing something wrong but I can import and export someone elses already animated model and their animations do work but the animations I create using 2.79 would only work in the SDK scene composer.

Trying to get the armature procedural failed no matter how I tried to get it, either calling getChild directly nor with traversal.


#34

hmm so even here is interpolation option :slight_smile: thanks.

anyway its much easier to select all keyframes and mark linear interpolation for all.


#35

I just tested newest script again and your bug still exists when using 2.79. Not sure about 2.8

I was able to get the armature using the .j3o but the animation overshoots the parameters set by the key.

Rotation is 90d but it goes past that which is not possible if you don’t set the rotation key past 90 so there is still something wrong with the script as far as I am concerned.

To date I have not been able to use the gltf exporter once without problems. I think this things been out for almost 4 years now?

Ogre still kicks its ass in my world. Even though the script hasn’t been updated forever.


#36

its ok if it only exist in 2.79, because this plugin is for 2.8+ trully like they said on github page.

anyway if you could check 2.8 and write note for them or even create new issue, because it is related but looks like some other issue.

im not sure how it go past 90 degree, you check it in files manually? or in jme?


#37

In jme.

I will wait till they get out of beta.

Have to say that so far I find it to be a bit more work than anyone should have to do just to export something or even use it in jme.

Always just one more problem every time you beat one.


#38

im using 2.79b with old exporter, i got no problems, its stable. i exported single cube from 2.8 and new plugin using interpolation like @Ali_RS said and it worked fine, but i dont check exactly 90 degree to see if it go past.

if you say it go past i belive, so i prefer stick with 2.79, but there might be user fail. maybe @Ali_RS know something more why it go past it? maybe other hidden blender option :slight_smile:


#39

I noticed they added a weighted normals modifier. This is really cool, not sure if it only lets you have weights by face area or you can set the normals 100% to the largest face though. This is something that has been missing for a while and is great for game models, been using a script up till now.