Blender Export problem

After browsing both this forum and google in general I couldn’t find a solution to my problem so here it goes. Sorry, it may be somewaht long post :wink: bear with me if you please :slight_smile:

First, specifications:
Win7 64bit
JMonkey 3.0 stable (up to date according to SDK)
Blender 2.68a

also blender2ogre 0.6.0 with OgreCommandLineTools 1.7.2 installed in a default location.

First, although blender2ogre plugin is installed (visible menu, options and line in Export), after selecting any model more complicated the cube, Export option is greyed out. I’ve read somewhere that this plugin may or may not work with Blender 2.68…
Can anyone actually confirm this plugin working in that version of Blender?

Second, after giving up the Ogre, I tried to export in Wavefront format (default plugin installed with Blender). Although exporting works (sorta), loading the model in SDK causes error:

‘Unknown statement in OBJ! o’

Sigh…tried to fix that, and failed as well.

So, next option was to load .blend format, and later convert it to .j3o. But, although I can load model converted that way(yay!), texture appears all wrong or not at all. I was using UV mapping and in Blender everything seems Ok.

I have created trivial model, a cube with number on each side - cube.blend and cube.png (UV mapping texture) in assets/Textures folder (checked paths couple of times). Full path to texture was set in Blender.

When I choose ‘View model’ on cube.blend I get a warning (actually, seven warnings from full path to just assets folder):

‘Cannot locate resource: assets/Textures/cube.png (Flipped) (Mipmapped)’

Same thing happens when I convert that file to .j3o and ‘View model’ or load in Application.
I have no idea what I’m doing wrong, so any help is appraciated.


Not 100% relevant :: I use blender 2.68 64bit (nb not 2.68a) and Ogre Exporter 0.5.9 with no issues… (I had some issues with 0.5.8 which I think the SDK is packaged with… 0.5.9 includes fixes for 2.6x).

It’s worth a mention that in Blender, Ogre exporter 0.5.9 incorrectly lists itself as 0.5.8.

I don’t use the Blender Importer so I can’t help with anything on that side sorry.

Thanks for the answer, James. I experimented with both 0.5.8 and 0.6.0 versions of the plugin. Is 0.5.9 that much different?
I still can’t solve issues with Wavefront and .blend files.

But, after some more testing, 0.6.0 version of Ogre Exporter seems to work for some models, and for some the export option is unavailable/greyed out. Can’t really tell why. Must be something with a model, but don’t know what.

BTW downloaded version of Blender has 2.68a in filename, but from inside Blender it’s 2.68, so I guess it’s the same.