CubeMap does not show up

i can’t see the cubeMap of my scene. i’ve got this in the log:[patch]WARNING: Invalid texture: Texture 408fbecf

Cubemap textures must contain 6 data units.[/patch]it says there is something wrong with my image, but it looks like the examples.

my texture:

and my code:[java] rootNode.attachChild(SkyFactory.createSky(

assetManager, “Textures/SkyBox.png”, false));[/java]

what is my mistake?

This texture is not a valid cube map,

You need to export it as a dds file.

Look at this tutorial

then why is this in the JME wiki?

■JME3 supports cube maps in PNG, JPG, or (compressed) DDS format.

You can use a cube map with separate jpg files.

how? i don’t see it in the wiki.

i just tried exporting it to a dds file, and i’ve got the same results…

A dds file is multiple files in one. You need to cut the image into the single segments and use the SkyboxFactory method that takes images for north, south etc.

Follow the tutorial exactly, it explains how to split the images

thanks, it works now