Did it died?

@normen I see :stuck_out_tongue:

BTW the guy managing the site may have to be notificated that those domtooltips should not activate in java code blocks hahah, look at that error now, total gibberish :stuck_out_tongue:

-.- you mean me? Yes I know, the guys writing this plugin didn’t really think this through ^^

Hehe, sheep happens :stuck_out_tongue:

Anyhow, my error appears to be close to http://hub.jmonkeyengine.org/groups/general-2/forum/topic/assetnotfoundexception-canonical-path-absolute-path/

Stupid thing is, even if I change the path to the capital Buggy (in debug mode) it complains it’s not the same. I also tried changing the Buggy.j3m file to get rid of the problem (as it actually did contain a small case letter) but it still complains about the same error (including the small case letter while I changed that). Any chance you are loading the materials from another file? Can’t imagine it changing it into a small case letter to complain about it afterward by itself…

I dont know what model you try to load, the j3m file is I think not linked to the main mesh file, its a leftover from importing / creating the j3o sinbad.

It’s complaining about the Buggy’s material, I haven’t even changed anything yet, really :stuck_out_tongue:

I removed “Models/Buggy/Buggy.j3o” from the list of preload models now, which fixes the problem (by removal of the faulty object that is) but I believe it wasn’t even there in the test level, so no actual changes made so far I think. At least I can start doing the stuff I want now :wink:

@pspeed the audio seems fixed now by the way, thanks!

@normen I believe the particle systems are defined in the j3o files but I cannot find a way to edit their settings such as textures and the like while they do contain this information (with some crappy wordpad inspection a lot becomes clear). Any specific way to edit these? I love the system but I can’t figure out how to change the parameters in there, the sceneComposer gives me 0 options as far as I can see and the wiki’s all state ‘TODO’ when referring to this. Seeing you somehow DID create these files, I’d like to know how :stuck_out_tongue: So far I’ve always created them by code not by these little files :wink:

You can just edit them in the SceneComposer, via the ParticleEmitter properties and applying proper materials.

Ahem, just removed my previous post. For some reason my properties window was not showing up AT ALL. Had to open it manually but that really took a while to figure out -_-’


I’m starting to think my jMP is completely ****ed up, if I edit an effect and save it, I cannot open it anymore… ><

baalgarnaal said:
Oh and this one now all of a sudden after updating to nightly:
[java](absolute path here)/trunk/assets/Models/Buggy/buggy_glow.jpg&quot; doesn't match &quot;Models/buggy/buggy_glow.jpg&quot;[/java]

As you figured out, the Buggy versus buggy was the issue above. Making those match should have fixed it and was precisely the kind of error this was meant to find since once released that asset would have failed to be located.

If you fixed it and it is still erroring out then I need to see the new error. The one above is clearly pointing to an issue. I'd have to see the new one to determine the new issue.

Well @pspeed I think it was loading the material without looking into the j3m file at all as I fixed that one, and it kept giving the exact same error. I got rid of the model anyway so no point looking into that anymore :wink:

Now I just need to get this effect editor thing working…

Ah, so the asset name was wrong in some file… not in code. Got it.

I’m not gonna flood the forums with all little thing’s that don’t work for me but I think this is a serious bug:

Create a new Scene

-Add Particle Emitter


-Open other scene

  • Unable to open the just created scene.

    Anyone able to confirm?

    Perhaps the file gets screwed up somewhere when writing it. I also notice some temporary file showing up shortly when saving that sometimes doesn’t get removed but just stays there.

Well, @Kaelthas lately changed stuff in the ParticleEmitters, maybe serialization got broken? As said, its like running after a bunch of children here, nobody thinks about the fact that jMP is the frontend that most people use to access jME3 so this is what happens when I am away for some time :frowning:

And to get back to the nifty errors as well, it appears that if I use the design view, I first need to load a layer before changing the resolution, or I will get an error and jMP freezes. The stop sign in the bottom right is completely unclickable, but as the whole of jMP freezes that was to be expected.

And, it turns out that I need to load something into the sceneComposer to be able to load the GUI design bit, or jMP freezes before ever giving any error at all.

Okay, thanks for the info. The freezes generally have to do with the lwjgl canvas. But if there was an exception and it freezes afterwards, you can check the log of jmp for the error (the location can be found in the jMP about screen).

Here you go, cut out a lot of stuff to get to the important part. This is for the freeze when trying to switch resolutions in the design part before loading any layer or such:

[java]INFO [de.lessvoid.nifty.Nifty]: loadFromFile took [97]

INFO [de.lessvoid.nifty.Nifty]: gotoScreen []

INFO [de.lessvoid.nifty.Nifty]: gotoScreenInternal []

WARNING [de.lessvoid.nifty.Nifty]: screen [] not found

SEVERE [org.openide.util.Exceptions]


at de.lessvoid.nifty.Nifty.displayResolutionChanged(Nifty.java:685)

at de.lessvoid.nifty.Nifty.render(Nifty.java:270)

at com.jme3.gde.gui.multiview.NiftyJmeDisplay.postQueue(NiftyJmeDisplay.java:128)

at com.jme3.renderer.RenderManager.renderViewPort(RenderManager.java:1121)

at com.jme3.renderer.RenderManager.render(RenderManager.java:1159)

[catch] at com.jme3.gde.core.scene.SceneApplication.update(SceneApplication.java:238)

at com.jme3.system.lwjgl.LwjglAbstractDisplay.runLoop(LwjglAbstractDisplay.java:144)

at com.jme3.system.lwjgl.LwjglCanvas.runLoop(LwjglCanvas.java:199)

at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:218)

at java.lang.Thread.run(Thread.java:662)[/java]

Sounds reasonable, seeing I try to switch resolution with nifty stuff :stuck_out_tongue:

Above this piece there is a lot logging about loading nifty bits as defined in the xml, no problems there as far as I can see.

EDIT: Seems the error is quite clear now: No screen defined and trying to load a screen for the new resolution.

As a note on the side, it always shows up using a layout based the previous selected resolution instead of the current one when changing (while changing the cavas itself to the new one), is that already known? :wink:

Switching between screens is a bit strange yeah, thats known.

Well, @normen, kudo’s for the particle editor. Been playing for a while and I got some pretty impressive effects right away, too bad I can’t save em :stuck_out_tongue: One noteworthy result was setting the start size to 0 and end size to 5 while using a sphere of size 5, which gave pretty much the effect of the anomalies from STALKER, really nice to see, while using a quick mockup image for the particles I made a long time ago (which actually turns out to be perfect for any particle application so far). Looking forward to making some effects now, can’t wait till I can save again :stuck_out_tongue:

(oh and yeah I looked into the source a bit myself but I’m not very experienced in serialization, slept a bit too well during that class I think)

Ah and I just noticed that when clicking the color selection in the particle properties resets the color for it, so changing the alpha means repicking the color as well :stuck_out_tongue:

Hehe, just found nice drawing DVD’s in the internet that could be useful to create the game concept arts :smiley: :

(free download them on http://ebookee.org/ ;))

These 2 below have to do with the game:

A full list of Scott Robertson :slight_smile: :

Just some weeks of learning and VOILA ;).

baalgarnaal said:
Well, @normen, kudo's for the particle editor.

Thanks, its not even a Particle Editor, just a "byproduct" of a quite extensive SceneGraph visualization system ;)