Forum visual update?


#1

Dunno if it’s just me somehow, but seems like the forum front end just got updated:

Gotta say, it’s only slightly worse. :upside_down_face:

Everything’s a bit larger, as if trying to copy Reddit’s new redesign that’s set up this way to push more ads. Since there aren’t any ads here, there really doesn’t seem like a point for it. Are we supposed to view the site at 80% zoom now for no particular reason?


#2

Wow thanks 80% zoom fixed it for me.


#3

Lmao


#4

hmm, you say its larger for you?

funny, i think its smaller for me :smiley:


#5

I kept getting notifications that the world was ending and that I needed to update now. I updated now. I got some error messages. I scratched my head real hard, tried again like 3 times, then it told me “failed to migrate database, if you want to keep using the old one do this”. I did that, and it worked. I’m done scratching my head for the day.


#6

Hey @Momoko_Fan Long time no see! :slightly_smiling_face:


#7

Even though I’m a bit annoyed with everything being slightly bigger, on mobile the update fixed the header. Before you got the links that go to the absolute top of the website on desktop sticking out from beneath the header, now they aren’t there at all. A welcome change if you ask me.

EDIT: While we’re at it, what happened to PWA? I loved using the forum without firefox’s top bar showing up every time I scrolled up but then it just stopped working one day and now even the button to install the forum as pwa is gone.


#8

Sorry for this noob question but what is PWA? :blush:


#9

Progressive web app, I assume. It’s a fairly hidden thing on mobile chrome where you can export a site as an “app” that executes in chrome but runs in full screen. It requires the site to have some metadata json set up properly to work.


#10

As @MoffKalast said, it’s a way to run websites fullscreen as a native app.


#11

Should be fixed now. It required me to upload a 512x512 logo of the site…


#12

Sadly I don’t get the option to install as PWA currently :’(


#13

Eh, it’s not like it’ll be an important feature for at least a few years. Currently it’s about the same as supporting xp or something. Nobody uses it.


#14

Looks like a forum bug. Despite the fact that I uploaded the logo it still keeps telling me I need to upload the logo


#15

I’m not sure how Remy ended up restricting upload sizes, whether it was a setting in discourse or further up the chain. Some kind of ruby php.ini style setting or whatever. I think the limit is 20kb though. I’m pretty sure it’s a blanket setting and status doesn’t override it.


#16

it’s limited on nginx maybe?


#17

Discourse seems really cool and all… but the fact that you can’t limit users from posting images in a post while simultaneously supporting proper gravatars is a huge smell coming off of their codebase.

Makes me doubt everything else just a little bit more.