I need help with the SDK

I’ve been using jmonkey for a while now but i had to change pc’s so when i installed it again it just straight up doesn’t work, I can create projects but they don’t show up anywhere in the IDE, thing is, the program actually creates them because I cant make another proyect with the same name but theres just no way for me to work on it

Imgur

This is what my ide looks like with a project “open”

wow, first time i see SDK issue like this. This looks like nothing(no project) there.
Myself i would ask you if Netbeans 8 was working for you.(because SDK base on it). Also no error popup?

maybe @Darkchaos will know something.

Im gonna try using Netbeans and ill let you know

need to solve this issue, but if this will be too much pain, remember, you can use Engine without this JME SDK. You can use any SDK. JME SDK myself i just use to export models / preview models that can be done without it anyway.

Its a nice tool though, so i hope we will solve it somehow.

some tips further: here a lot of people use gradle as builder, and default model format is gltf -> .j3o workflow.

Go to help -> about. It gives you a folder where it writes temporary stuff.

Try clearing that.

1 Like

Do you know how do i use the engine in Netbeands for example?

You are in for a steep learning curve there.

Best to try and fix this problem before going there.

Did you try clearing the cache as @jayfella said?

Yep, still nothing

Have you restarted the SDK?

Multiple times, and i tried using the .exe and zip file on the downloads page

Can you paste the help->about here?

Yes

Product Version: jMonkeyEngine SDK v3.2.4-stable-sdk1

Java: 1.8.0_212; OpenJDK 64-Bit Server VM 25.212-b04

Runtime: OpenJDK Runtime Environment 1.8.0_212-b04

System: Windows 10 version 10.0 running on amd64; Cp1252; es_CO (jmonkeyplatform)

User directory: C:\Users\usuario\AppData\Roaming.jmonkeyplatform\v3.2.4-stable-sdk1

Cache directory: C:\Users\usuario\AppData\Roaming.jmonkeyplatform\v3.2.4-stable-sdk1\var\cache

Are you running as administrator? At least the first time?

Just tried it out and nothing changed

This probably wont help but have you tried exporting your settings from old version of SDK and importing them into new?

I had to change my pc as i stated in the post so I dont have those settings
Im currently installing and older version of the SDK to see if it somehow works

I can tell you that I have had this exact same thing happen where none of the buttons were showing like for importing, converting to j3o, open in blender, etc. and it was only fixed by re-install.

You can also check under plugins to see if all the plugins are installed and activated.

i’ve tried also reinstalling :confused:

All green for you?

Ok, i gave up fixing the SKD and just imported to Netbeans, i have to work on a code now so for the time being im gonna work on Netbeans, ty for all your help tho!