Image format 'DXT1A' is unsupported by the video hardware


I am trying to get the JMonkeyEngine SDK working.
I have ran a few of the test examples the SDK comes with, some work fine, e.g:

class jme3test.model.TestObjLoading
class jme3test.model.TestOgreLoading
class jme3test.model.TestOgreLoading
class jme3test.model.shape.TestDebugShapes
class jme3test.bullet.TestRagdollCharacter

Others, such as:

class jme3test.bullet.TestWalkingChar

Give me the following error:

Feb 14, 2016 7:42:00 PM handleError
SEVERE: Uncaught exception thrown in Thread[LWJGL Renderer Thread,6,main]
com.jme3.renderer.RendererException: Image format ‘DXT1A’ is unsupported by the video hardware.
at com.jme3.renderer.lwjgl.TextureUtil.getImageFormatWithError(
at com.jme3.renderer.lwjgl.TextureUtil.uploadTexture(
at com.jme3.renderer.lwjgl.LwjglRenderer.updateTexImageData(
at com.jme3.renderer.lwjgl.LwjglRenderer.setTexture(
at com.jme3.material.MatParamTexture.apply(
at com.jme3.material.Material.render(
at com.jme3.renderer.RenderManager.renderGeometry(
at com.jme3.renderer.queue.RenderQueue.renderGeometryList(
at com.jme3.renderer.queue.RenderQueue.renderQueue(
at com.jme3.renderer.RenderManager.renderViewPortQueues(
at com.jme3.renderer.RenderManager.flushQueue(
at com.jme3.renderer.RenderManager.renderViewPort(
at com.jme3.renderer.RenderManager.render(
at com.jme3.system.lwjgl.LwjglAbstractDisplay.runLoop(
at com.jme3.system.lwjgl.LwjglDisplay.runLoop(

I have seen this thread:

And have tried “export force_s3tc_enable=true” but still have the same issue.

System specs:

OS: BunsenLabs (Debian 8.3 64-bit)

Kernel driver in use: i915

jmonkeyEngine SDK 3.0 output:

Running on jMonkeyEngine 3.0.10
Extraction Directory: /home/user/.jmonkeyplatform/3.0
Lwjgl 2.9.0 context running on thread LWJGL Renderer Thread
Adapter: null
Driver Version: null
Vendor: Intel Open Source Technology Center
OpenGL Version: 2.1 Mesa 10.3.2
Renderer: Mesa DRI Mobile Intel® GM45 Express Chipset
GLSL Ver: 1.20
Audio Device: OpenAL Soft
Audio Vendor: OpenAL Community
Audio Renderer: OpenAL Soft
Audio Version: 1.1 ALSOFT 1.15.1
AudioRenderer supports 64 channels
Audio effect extension version: 1.0
Audio max auxilary sends: 4
Returning hash code of content
Returning hash code of content
Checking page id 256,898,459 vs stored id 256,898,459

Can anyone help?


I googled a little and maybe you don’t have the required libraries installed:

Yes, this fixed it.
Thank you very much, jmaasing. :grinning: