JME3.1 not working at all!

Hey all,

I’m new here. I want to start 3-d developing in Java and this is the best engine I found. I really enjoy using eclipse but when I tried to install the jars it gave me an error about the view not loading (below). Next I tried to use the JME SDK with the same code (from the documentation) but it gave me the same error. Help please!

Here is the error:
Aug 22, 2017 5:53:00 PM java.util.prefs.WindowsPreferences
WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(…) returned error code 5.
Aug 22, 2017 5:53:03 PM com.jme3.system.JmeDesktopSystem initialize
INFO: Running on jMonkeyEngine 3.1-stable

  • Branch: HEAD
  • Git Hash: af04bf9
  • Build Date: 2017-02-19
    Aug 22, 2017 5:53:09 PM handleError
    SEVERE: Failed to create display
    org.lwjgl.LWJGLException: Pixel format not accelerated
    at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
    at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(
    at org.lwjgl.opengl.WindowsDisplay.createWindow(
    at org.lwjgl.opengl.Display.createWindow(
    at org.lwjgl.opengl.Display.create(
    at org.lwjgl.opengl.Display.create(
    at com.jme3.system.lwjgl.LwjglDisplay.createContext(
    at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(

Aug 22, 2017 5:53:09 PM com.jme3.system.lwjgl.LwjglAbstractDisplay run
SEVERE: Display initialization failed. Cannot continue.
BUILD SUCCESSFUL (total time: 13 seconds)

Thank you!

Might be due to your graphics card? Did you try to update your drivers?

There shouldn’t be perhaps need to run in in admin mode, but somehow it seems to fail to create some keys to registry. You could try starting it in admin mode just to see if it helps.

I can’t recall now do I run it in admin mode. But at least Visual Studio and Eclipse I do run in admin mode, they’ll fail in some weird point otherwise…

That Registry Key is only a Minor issue (it prevents saving the App Settings iirc).

See you running in a vm or Maybe your CPUs igpu?

In General what Hardware do you use?

JME3 requires OpenGL2 to run.You should check if your GPU currently supports that.You can use this program:
Or from the SDK menu,
“Help/Check Graphics Capabilities”