JMonkeyPlattform AutoUpdate doesnt work

Hello,

i like to update my:



jmonkeyplattform core from 0.8.0.6961 to 0.8.0.7059

Project JMe3 from 0.8.0.6961 to 0.8.0.7059



if it starts update, it goes to ~ 50% and then it aborts and said it doesnt have internetconnection.

All other softwareupdates work.





Can somebody help me?



regards,

Max

I just sometimes experience slow downloads of updates at the moment, not complete fails. Where do you live?

thanks for the fast response,



i live in germany… i tried to download the nightbuild but it only loads with 5kb/s lol ( i have 100mbit/s connection).





regards,

Max

Hi, same problem here



I’m from spain, 100mbit/s connection and since 2 days jMonkeyPlatform Core updates or Project jm3 updates get stuck at 1% or 2%, and the rest, one by one take at least 1 or 2 minutes (sometimes i have to cancel them and update again too)



regards

Hi there jMonkeys,



Nightly build updates are failing for me also - and have been now for several days (I am in the UK). I’ve tried leaving it for hours, I’ve tried repeatedly restarting the update, I’ve tried updating at different times of day or night - still no dice :frowning: it just gets stuck and stops, no error is given. Once it got about halfway, but most of the time it’s not even getting up to 10%.



I’ve found another thread about failing updates:-

http://hub.jmonkeyengine.org/groups/general-2/forum/topic/unable-to-update/

…alas, also with no solution.



I was particularly hoping some progress had been made on the scene viewer window crashing on startup - cos at the moment I get a rude exception on startup and my gui is partly broken because of this.



Does anyone have any news on when updates will be working ok again?

You can also do:

svn co http://jmonkeyengine.googlecode.com/svn/trunk/ jme3
cd jme3
ant run

To get the latest nightly ;)

Hmmm, good suggestion - but still no dice unfortunately.



For me the ant build hangs when it tries to download platform-base.zip from jmonkeyengine.com – it just stops and sits here:-



groovemonkey@dimension:~/workspace/jme3$ ant run

Buildfile: /home/groovemonkey/workspace/jme3/build.xml



-check-platform-present:



-check-platform:

[echo] Downloading base platform, this only has to be done once.

[get] Getting: http://jmonkeyengine.com/platform/base/alpha/platform-base.zip

[get] To: /home/groovemonkey/workspace/jme3/platform-base.zip



…and network activity grinds to a halt. It’s done nothing for about 20mins or so - but, I’m hopeful, so I’ll leave it for another half-hour or so… maybe it is downloading, but just really really slowly?



Is it possible to download platform-base.zip from another source to kickstart the build?

Or, alternatively, is it possible to build whatever is in platform-base.zip? (I’m guessing this zip contains the netbeans base?)



Thanks.

narf… well, I am uploading a version to googlecode now… this has something to do with our server or backbone, for some big downloads seem to get interrupted or something…

Check the download list here:

http://code.google.com/p/jmonkeyengine/downloads/list



you have to unzip the contained netbeans folder to the folder you downloaded trunk to so its next to the sdk and engine folders

I also changed the svn build script to use the googlecode version for now, so the following should work now:

svn co http://jmonkeyengine.googlecode.com/svn/trunk/ jme3
cd jme3
ant run

Woot! ~ thanks Normen! That did the trick - I’m now up and running again :slight_smile: I hope you get your server/backbone problems fixed soon.



Thank you very much for your time and assistance.

…is there a way to run the built project, besides executing ‘ant run’…?



Every time I execute ‘ant run’ it takes a couple of mins checking the build is ok and rebuilding the javadocs.



Do you have any tips?

do “ant run” in the sdk directory, but each time you “svn update” in the root folder you should do the main “ant run”

Hmm… that’s a bit quicker, thanks – but it still takes quite some time.



Is there any way (a script maybe?) to just launch the SDK that was previously built, without checking all the build deps and stuff??

You can create a distribution version using “ant zip”

Thanks Normen.

I am a bit confused with the updating mechanism.



From the alpha 4 download, updating is currently broken. Its currently impossible to finish a complete update for the last few days.

From what I can gather, I can grab the stuff directly from svn and do an ant run. Here is the confusing part: it gets me the regular alpha 4 and I need to do a complete update. If I get the trunk, shouldn’t I get the latest nightly too?



PS. I know this is alpha software.

PPS. You guys rock.

Its not the regular alpha-4, it just does not add the svn revision to the version number on build.



Also… You cannot update alpha-4 but with the nightly you can??

neither. Both hangs at the downloading plugins step.

Well as said I can update, its just really, really slow at the moment.

Hi, one question: after doing the “svn checkout” and the “ant run”, the final step should be copying the “engine/dist/lib” generated jars and replace (in Windows) the “AppData/Roaming/.jmonkeyplatform/dev/libs” jars?