Lights and texture

Texture in blender (in top)
Textured level in jmonkey (down)

How to make texture visible in jomnkey?

If youre using regular phong lighting you need to add an AmbientLight. If you’re using PBR you need to add a LightProbe.

1 Like

In later versions of JME, I think an ambient light also works for PBR… but a light probe will look way better.

private void setUpLight() {
// We add light so we see the scene
AmbientLight al = new AmbientLight();

DirectionalLight dl = new DirectionalLight();
dl.setDirection(new Vector3f(2.8f, -2.8f, -2.8f).normalizeLocal());

I’ve never got an ambient light to affect PBR materials. Maybe there’s a flag or something in the material.

To the OP: you need a light probe.

I asked nehon for a setting for an ambient color value and instead he added support an ambient light. All of the normal caveats still apply about making sure your material has an ambient color, etc… I guess. The defaults are really dark.

A light probe, even a default one, is still better… but I start PBR scenes all the time with just a direct light and ambient. I’ll try to make an example some time.

but it was changed some time ago and ambient affect PBR intensity

about author topic, blender use own lighting in third mode, anyway he got many lights there too, but it dont matter, blender show them only in forth view. Texture is not visible in JME because i assume ambient light affect metallic, but probably it require other light? idk, or he use older version that dont have this change.

Maybe it’s the ambient colour On the material as Paul mentioned. I’ll have a look tomorrow.