Missing dependencies in some 3.1.0-SNAPSHOT libraries

I would like to use the new jMonkey 3.1.0-SNAPSHOT libraries in my projects, but there seems to be missing dependencies in some of the libraries. I used maven to get them from the jME repository (http://updates.jmonkeyengine.org/maven/). So far I found the following issues:

Here should exist a dependency to jbullet, but it is missing in the pom.xml for 3.1.0-SNAPSHOT. In the pom of 3.0.10, this dependency is still defined.

Here are some dependencies defined in the 3.1.0-SNAPSHOT, but there is no maven repository defined, from which to get these libraries. It should propably be Index of /nifty-maven-repo.

Hope, this could be fixed in the near future, because I can’t wait to use the new Version 3.1. :grinning:

Nifty GUI dependencies are supposed to come from the nifty gui maven repository, there are no problems there.

As for the JBullet issue, it is already reported here:

Yes, that is the point. To get these dependencies, you have to define the maven repository to get them from. Therefore you should add something like this to your pom.xml:


Currently I have to add this to my own pom.xml in order to get the jme-niftygui dependency correctly. But why is the needed repository not already defined in the pom.xml of the requested dependency itself? So, wouldn’t it be nice to add the few xml line above to the pom.xml of jme-niftygui?

OK, the next snapshot should have the proper repository reference set now.

I made the change here:

1 Like

@Momoko_Fan Nice, now it’s working fine. Thanks to you.

@Momoko_Fan The problem with the missing dependencies still seems to be present in all the alpha and beta releases of jMonkey 3.1.

At the time I reported them, you added the missing repo for nifty-gui and it worked, but in the newer releases with the new groupId org.jmonkeyengine it is still missing. Can you please add the missing repo, like you did the last time?

The bug for the missing dependencies for jBullet (https://github.com/jMonkeyEngine/jmonkeyengine/issues/327) is also in status open. I’m not sure, if I understand the problem. For me, it worked to simply add the dependency for jBullet to my pom.xml, like so:


I know, this was for the older version of jME, but can’t you do a similar thing to the pom.xml of jme3-jbullet?

Yeah, looks like that change was not kept after the BinTray publishing was added. Anyways, it’s now restored: