Monthly Gallery site

Hello guys :chimpanzee_closedlaugh:

With the conjuncted efforts of @aegroto, I made the Monthly Gallery website available now at this link:
http://monthly.jmonkeyengine.org/

By default all the images posted in the Monthly Gallery threads are included.
Specific images can be excluded by adding #excluded at the end of the url.

GitHub repo: https://github.com/riccardobl/JME-Monthly-gallery

8 Likes

All I see is a spinning banana… the arrow buttons do nothing. I’m using Firefox 44.0.2 on Ubuntu Linux 14.04.3 LTS x64.

I see a spinning banana too…

Which browser are you using?
Do you have any kind of ad blocker or something?
Note that it takes a while for loading.

Spinning banana here… then eventually loaded as I was looking up the “I’m a banana!” video on youtube.

P.S.: Looks very nice.

Yeah, the loading is quite slow, also because i’m using a proxy for the CORS requests, I will ask to the competent authorities :chimpanzee_winktongue: if it’s possible to allow direct access to the forum.

Spins 7 seconds and then it’s there.
However it’s a bit laggy: Are those full screen images? (like downscaled but not at a lower resolution?)

Also: The Bottom-Font might look nice when it’s not Bold, just a feeling though.

Yes, since it’s all client side.

I use uBlock, although disabling it has no effect. I noticed that when I loaded it via HTTPs (your certificate is okay for a random OVH domain but not for yours – I recommend Lets Encrypt for a certificate) everything works fine after a few seconds. I’m using HTTPs everywhere, but it isn’t set to block insecure requests – so I doubt it is related.

EDIT: If you want some help setting up faster hosting (with HTTPs) feel free to ask me. I’ve setup many websites for Minecraft servers and this doesn’t seem to be all that different.

This happen because it’s hosted on OVH object storage, i have no direct control over the ssl cert, i will see if i can do something about.

Why not just get a simple OVH vps and install nginx or apache? Since the images are loaded from jme-cdn I doubt that bandwidth would be an issue. If it would be, then just use Cloudflare or get the cheapest Kimsufi.

Works for me on Firefox 44.0.2. As for the others a bit long the first time (spinning banana <3). Changing month is ok too.

So many images wtf mixed with real projects…needs time to mark all of those with #excluded :wink:

I use uBlock, although disabling it has no effect.

If you open this link http://development.jme-monthly-gallery.frk.wf/ you can see a version of the gallery with debug enabled, so you can tell what is happening by looking at the web console. Tools -> Web Developer -> Web Console in firefox

I got a lot of debug “Image corrupt or truncated.”

And two warning : (in french sorry)
“L’utilisation d’XMLHttpRequest de façon synchrone sur le fil d’exécution principal est obsolète à cause de son impact négatif sur la navigation de l’utilisateur final. Consulter http://xhr.spec.whatwg.org/ pour plus d’informations.”

“L’utilisation des « Mutation Events » est obsolète. Utiliser « MutationObserver » à la place”

I think I found the error. The fix is to just add jQuery to the same domain name as the actual page rather than loading it from a separate CDN.

This error only occurs in the insecure version:

Can you post the link of the images you see corrupted?

That’s weird… those domains should have CORS enabled… fixing…

Console gave me this (Safari on latest OSX)

[Error] Failed to load resource: Request header field Accept-Encoding is not allowed by Access-Control-Allow-Headers. (jquery.fullscreen.js, line 0)
[Error] XMLHttpRequest cannot load https://gist.githubusercontent.com/johan/2128691/raw/b81d1b59fd98091a1a2c8814f77660a10a9b0e16/jquery.fullscreen.js. Request header field Accept-Encoding is not allowed by Access-Control-Allow-Headers.
[Log] [962ms] Cannot import //gist.githubusercontent.com/johan/2128691/raw/b81d1b59fd98091a1a2c8814f77660a10a9b0e16/jquery.fullscreen.js (debug.js, line 32)

Should be fixed now.

Now I get a Monkey with a question mark and the message “Thread not found” on the page with this console output:

[Error] Failed to load resource: Request header field Accept-Encoding is not allowed by Access-Control-Allow-Headers. (34977.json, line 0)
[Error] XMLHttpRequest cannot load http://cors-gate-for-the-internette.frk.wf/http!hub.jmonkeyengine.org/t/february-2016-monthly-wip-screenshot-thread/34977.json?page=1. Request header field Accept-Encoding is not allowed by Access-Control-Allow-Headers.
[Log] [853ms] Mon Feb 01 2016 00:00:00 GMT+0100 (CET) - Mon Feb 01 2016 00:00:00 GMT+0100 (CET) = 0 (debug.js, line 32)