Motorolla defy JME3 project

I run the jme3.tests.helloworld.HelloCollision on my phone and i recive that exception

any ideas?

What’s your phone spec?

Motorola defy Android 2.2 supported OpenGLES 2.0

how do you made the screenshot on the defy?

It`s getting better and better. We tried to run the simple box application genereted when you start a new project, that worked previously. Now it generates the same error(maybe it happend after a recent update?). Any ideas?

@kernproblem said:
how do you made the screenshot on the defy?

by connecting it to the pc and using ddms in androidsdk/tools

I have a suggestion that maybe, the developers accidently used:

public static void glVertexAttribPointer (int indx, int size, int type, boolean normalized, int stride, Buffer ptr)

Since: API Level 8

public static void glVertexAttribPointer (int indx, int size, int type, boolean normalized, int stride, int offset)

Since: API Level 9

the second call of function, that is in API 9, making impossible for working in API 8. Is there any posibility to fix that?

1 Like

You are right, the latter is used in one case. I committed a fix for this, maybe you can try if it works tomorrow when the build is through, I cannot test it as I have no Android device.

@Momoko_Fan just told me that the signature is needed for VBO to work but this is in fact the issue. The code check makes it fail although the code in question would not be executed. The solution involves separating the call into another class, lets see when this happens, I guess its before the next stable update push (which should be sometime this weekend).

OK It should be fixed now …

I replace the jMonkeyEngine.jar in the poroject with the one located in jME3_2011-11-12/opt/android(nightlybuild), still generates the same error


Any suggestions? Maybe im doing something wrong?

i tried the same lib from today`s build as well, no luck.

But the exception is thrown in a new location no? If not then you didn’t update the library. How do you update anyway?

indeed it looks like it is in different locations here is the log:

And i add the library removing the old one and adding new jar…

Add the library where? The stack is not from the new version.

I add the jmonkeyengine.jar library to project libraries as a jar file. So im doing something wrong?

In eclipse? For the SDK, just update to nightly via Tools->Plugins->Settings. The android version of jme3 is not to be added to the SDK main project, its added automatically to the android sub-project.

ups, my bad. Im not exactly sure how it happend, but i had nightly unchecked, so it didn`t show me any updates. fail. Yet something strange occurs after the update - when i choose the option android device it compiles only pc files, and runs on pc.

Update the android SDK and then the project as well by going to the Android settings of the Project once.

I managed to fix it. Yet the problem on android is still unsolved.