Need to change method name Quaternion.multLocal(Vector3f)

Quaternion.multLocal(Vector3f) method name seems to weird.

Need to change method name or move to Vector3f class.

Matrix3f.multLocal(Vector3f) also.

hm? what is the problem with them? I think they fit into the jme naming sheme

Yeah, every monkey should know that one by now. :wink: I also think it is ok and fits its class perferctly.

Generally, A.xxxLocal() modify value of A. But the two methods doesn’t.

It confuses for me. maybe just for me :wink:

When you multiply a matrix and a vector, you get a vector as a result. It makes no sense to modify the matrix.

But yeah you’re right about it being inconsistent.

Quaternion.multToStore(Vector3f store)

or something like that are probably better?

Guys, I think its fine. Why introduce another method type for two computations? Quaternion “multiplied” with a vector does not make sense anyway… Its kinda obvious this does something else…

@EmpirePhoenix, I think that’s even more complicated.



The idea of ‘multLocal’ is pretty well propagated throughout the engine and is a good and concise way to describe it (in my opinion, of course), and the javadocs make it plain as day. If we change this then we’ve have to also change the name of the non-void method that returns a new value to something more verbose.



While we’re changing the Quaternion class, we’d also go in to change Vector3f… Before you know it, we’d be refactoring half of the math package :confused:

hm yeah i see the problem with renaming it ^^