Next Engine release

Hey guys!

Unless someone is planning to do this, I want to manage the v3.6 release. This would be my first time releasing the engine and I hope everything goes smoothly.

I want to thank @sgold for helping me in this process.

You can expect an alpha-1 release soon. I will announce further steps as we progress.


Created 3.6.0 Milestone on GitHub if you want to take a look

There are 21 open PRs. Some are still not reviewed or are not finished (drafted). You can take a look at them here:

I could review one of them and added it to the milestone. The rest of them were outside of my capabilities.

Please let me know if anyone is willing to review any of them so that we can include them in the next release.


Happy New Year everyone,
thanks to @Ali_RS, @sgold and the whole community for the new release process that has started!

I was wondering if it is possible to fix this bug on particle effects in the next engine release? It would be very helpful to unlock so many cool effects with stock engine particles.
Thank you all for the support.


Happy new year everyone!

jMonkeyEngine 3.6.0-alpha1 is now released and available on maven central. You can see the change log here:

I am considering a 3 weeks period for alpha testing then I will freeze the feature set and we will move to beta testing. Please try it out and report it if you find a bug.

Going to take a look at it.


I submitted a fix


A new regression report in 3.6 that seems to affect Nifty GUI when the app is in fullscreen. I could not reproduce the issue in my Linux box. Can someone else try to see if they can reproduce this issue?


I also couldn’t reproduce it, even after trying many times.


Wow, that’s amazing ! Very well documented, thank you !
Unfortunately, i am currently preparing for my medical exams, it will start in 3 days and end by January 20, i wonder if the due testing date can be extended to at the end of January at least ? If not, it’s okay i may catch up on Beta.

1 Like

I plan to cut the 3.6.0-alpha2 in about 12H.

You can track the issues that are resolved in the below link, there will be a detailed change log added later on soon.

Thanks to all the people who helped with testing and bug fixing :slightly_smiling_face:


Here we go!

As I promised v3.6.0-alpha2 release is published and available in maven central. Please see the change log for new features and bug fixes.

this release uses the LWJGL v2.9.4 release from our lwjgl2 fork here: GitHub - jMonkeyEngine/lwjgl2: [LEGACY] LWJGL 2.X - The Lightweight Java Game Library. which fixed issues with java 11+ on Linux thanks to @Darkchaos

Also thanks @yaRnMcDonuts and @rickard for their contributions to the new release.

Special thanks to @sgold for all their help :heart:

Please test the new release in your JME projects and report if you find an issue.

@capdevon this issue is fixed in the new release. Please try it out and let me know if you had an issue.



I will do. thank you

error: cannot find symbol
  symbol:   class VideoRecorderAppState
  location: package

Why was removed? Any workaround available?

1 Like

It is not removed. Still there on the master.

Do you have the jme3-desktop dependency added?

I only had this:

implementation "org.jmonkeyengine:jme3-lwjgl3:$jmeVersion"

because it was enough with 3.5.2.

Adding the jme3-desktop solved that but now I get:

gen 12, 2023 2:45:20 PM handleError
GRAVE: Uncaught exception thrown in Thread[jME3 Main,5,main]
java.lang.NoSuchMethodError: java.nio.ByteBuffer.clear()Ljava/nio/ByteBuffer;
	at com.jme3.util.BufferUtils.createByteBuffer(
	at com.jme3.system.lwjgl.LwjglWindow.imageToGLFWImage(
	at com.jme3.system.lwjgl.LwjglWindow.imagesToGLFWImages(
	at com.jme3.system.lwjgl.LwjglWindow.setWindowIcon(
	at com.jme3.system.lwjgl.LwjglWindow.createContext(
	at com.jme3.system.lwjgl.LwjglWindow.initInThread(
	at com.jme3.system.lwjgl.LwjglWindow.create(

Java 8 btw!



I thought it has been fixed!!

Please use java 11 or above until we can fix it!


If someone has an idea why the above issue happens please help.


Well, this may happen with non-oracle JDKs, but this should never happen with oracle-jdk-8.

@Pesegato Are you using oracle jdk ? If you aren’t, please check the /jdk-1.8/lib/ file for the java/nio/ByteBuffer class, does it really hold this method ?

1 Like

It works fine with JME 3.5. So I believe something is wrong on our side, probably with our GitHub builds.

Please see the details in


The thing is, according to the javadoc, even Java8 does not contain this method:


clear():Buffer, yes. clear():ByteBuffer, no.

Edit: JDK18 does have it:

…so somewhere between JDK11 and JDK18, the ByteBuffer.clear():ByteBuffer override was added.

I think the JME release must be being compiled with a newer JDK.


I’ve tried with

oracle jdk (I know, very old)
oracle jdk
Zulu (newer)

They all have the same issue. Amazon corretto 11 works.

…And indeed the method doesn’t exist on the src!


Hmm, that’s one explanation to the issue, there is a conflict between jme compiled byte class files (inside jme jars) and the user JDK compiling the project (the user jdk cannot find the ByteBuffer.clear():ByteBuffer compiled from jme side)

1 Like