No shading on model with texture

Hi everybody

I Imported an obj-model from blender (normals enabled), but JME does not apply appropriate shading, as this image shows:

ShadeState is set to ShadeMode.Smooth.

I would be very grateful for any Help!



In the OBJ exporter in blender, you must select high quality (HQ) normal export option.

Thanx for the answer. I actually enabled HQ normal. Those are the settings I used to export the model:

Maybe it is suspicious that the tooltip says: “Export vertex normal data (ignored on import)”?

When i use the original model, an obj-file as well, shading works in JME. Blender seems to loos data or to “forget” something when exporting the model.

Any ideas?



Does the object look correct when renderered in Blender3D? Try pressing F12 and see how it looks.

If not, you need to turn on smooth shading in Blender, select your model, press TAB to enter edit mode, press F9 to enter editing options, then select "Set Smooth" under Link and Materials.

Perfect  :slight_smile:

Thank you very much for your help!!!