NPE when loading a model through the blender importer

Hello @Kaelthas,

I was told by @Normen to contact you through here…
I recently downloaded a model from blenderswap, and ran into the following stacktrace when I tried loading it through the blender importer in the SDK. This is the model I’m having the problem with:
metal box

I hope you can fix this as a like the model. But in the end, it’s just a placeholder, I think.


at com.jme3.scene.plugins.blender.modifiers.ObjectAnimationModifier.(
at com.jme3.scene.plugins.blender.modifiers.ModifierHelper.readAnimationModifier250(
at com.jme3.scene.plugins.blender.modifiers.ModifierHelper.readModifiers(
at com.jme3.scene.plugins.blender.objects.ObjectHelper.toObject(
at com.jme3.scene.plugins.blender.AbstractBlenderLoader.toObject(
at com.jme3.scene.plugins.blender.BlenderLoader.toObject(
at com.jme3.scene.plugins.blender.BlenderModelLoader.load(
at com.jme3.scene.plugins.blender.BlenderModelLoader.load(
at com.jme3.asset.DesktopAssetManager.loadAsset(
at com.jme3.asset.DesktopAssetManager.loadModel(

Changed the mention to the right name @Kaelthas :wink:


I had NPE while loading object animation for a moment. But I solved it.
I imported your model without problems today.
Try updating to the newest version maybe this will help :slight_smile:

1 Like

I just tried updating my version, but no new updates were found. So as far as I can tell, everything is at the latest update. Or do I need some non-standard plugin?
I downloaded the model zip from the link provided and just did the “import model” in the sdk.
I’m just using the standard plugin repositories, not the nightly build ones.

Well he talks about nightly.

Yeah I definitely talked about nightly builds :slight_smile:
Try using them and tell me if it loads.


Ah ok, just turned on the nightly repo for the SDK. Now it loads perfectly. Thanks.

1 Like