Problem using physics, cannot run tests


I’ve downloaded physics2 from cvs as in wiki tutorial and I have added jars to libraries and finally libraries to my project. Test for physics (TestChooser) or PhysicsGameState tutorial won’t work. After I run it the application is instantly terminated, no output. If I remove for example ODE library then black opengl window pops up but of course nothing else happens since no class def found exception is thrown.

Anybody knows what is the case with this? I don’t know where to start investigating, or what to look for…

btw. my plan is to learn physics2, but I see there is not a lot of tutorials or anything. So where do I learn from, reading javadoc? hope not :slight_smile:

No output is really stange. What IDE and OS are you using? Try debugging an application and have a look where it's bailing out.

Looking at the tests should get you started. It's simple to use jME Physics 2 (or should be ;)). But beware: it's not simple to model physics the way you want it to behave and keep it fast. That's the problem with all complex physics engines.

I'm using eclipse 3.2.2. and win xp, jre 1.6.0

I've tried debuging, in PhysicsGameStateTutorial  app crashes at game.start() :

final StandardGame game = new StandardGame("Physics tutorial");
        game.start(); <---

with <terminated, exit value: -1073741819>C:Program FilesJavajdk1.6.0binjavaw.exe (2007.07.08 19:01:15)

and in physics2 TestChooser in first line of getting system UI:

    public static void main( String[] args ) {
        try {
            UIManager.setLookAndFeel( UIManager.getSystemLookAndFeelClassName() );  <---
        } catch ( Exception e ) {
            //ok, keep the ugly one then :
        new TestChooser().start( args );

with <terminated, exit value: -1073741819>C:Program FilesJavajdk1.6.0binjavaw.exe (2007.07.08 18:59:55)

Strange exit codes...
I've tried to go deeper in jme source with "go into" but it doesn't work, debug doesn't follow anywhere, just instant crash. I don't know why, but I think in normal circumstances you should have been able to do that, I remember I did "go into" some of JRE's sources while debugging network, didn't do anything, just remember you can do this. If I manually open the class (StandardGame) and put a breakpoint, at debug time I get "Unable to install breakpoint in .... due to missing line number arguments. modify compiler to generate line number attributes." from eclipse.
Any clues? :)
Running jme applications and jme tests works fine.

I've seen to find the "problem" :) ...
irrisor said:

There are currently two versions of jME Physics. The complete/production/old one on sourceforge:

and the redesigned/incomplete/new jME Physics 2 on

Please use the one from sourceforge for existing projects. I will post here again as soon as I recommend to migrate to the new one.

... the instructions in wiki are for repository on, probably just c/p from "setting jme tutorial", I'll try physics from sourceforge now.

an addon, I've been able to capture debug status of threads running, they shutdown pretty fast :wink: There is max 3 threads started, "main", "awt-shutdown" and "awt-windows".

I'll try updating everything, starting from scratch and so on…


I've found the problem. I have keyboard/system logger installed (KGB Keylogger) and after I turned it off it worked. Shame, it's a good, free logger and I was using it over a month with various programs.

I've find it strange that physics libs would interfere with it :slight_smile:

Don't, you won't be happy with it. If you start a new project and are learning jME Physics 2 is the right one for you.

According to your post, Physics 2 isn't ready yet?

If it is ready for testing, then I'm back to my original crash problem.

According to that post it is ready for testing (even using) for new projects.

Your crashes are really strange, I have no idea what’s happening there. Did you try updating your jdk, already? If that does not help rebuild the jars - probably with a different tool.