Problem with Shadows

First of all, i want to say that you´r Engine is fuc**** Amazing! :slight_smile:
I love Java and i programming Games, mods and maps for years.
But i havnt seen such a powerfull Java Engine before.

To my probelm:

I use Cinema4D and OgreExporter for the Models and in some case the light
seems to be buggy. The Materials are all UVW-Textures and when i open the level-chunks
in the SceneComposer then i have same light problem so it must be a
Material or a mesh issue (I think).

Here are some Images:

Bild hochladen
Bild hochladen
Bild hochladen
Bild hochladen

I use a Flashlight (Spotlight) with ColorRGBA.White.mult(2.0f) and AmbientLight with ColorRGBA.White.mult(1.3f).
As you can see the shadows are showen different although they have the same material and ShadowMode.

The mesh´s are Triangulated. I try to figure out for 2 weeks and search in the Forum, but i cant find a solution.
I have edit the material file manuell, but nothing changed.

Thanxs for help :smiley:

Looks like an issue with normals, make sure they are correct in the model editor.

Thank you Momoko for the quick reply :slight_smile:

Hmm … You mean the Faces of the Models?
They are all on the upper Side (Orange) …

Bild hochladen
Bild hochladen

Can they change while exporting? I have check the Normal Export Option.

No, not the faces of the model, but the normals of the faces of the model. There has to be an option like that in Cinema4D, look it up online.

Hm ok. Looked up online for that, in Cinema4D there are 2 Options to edit Normals of Faces.
Under “Options -> Normals” you can display the Normals of the faces of the Model.

Bild hochladen
As you can see, all Normals of the Faces of the Model are in the right direction.

There are 2 Options in Cinema4D: First is “align Normal”. Secound is “Switch Normal”.
Bild hochladen

Both options didn´t help me with my issue. I´ve also install a plugin for better Normals handling, called “Normal Tag” and read in Forums about it.
But NOTHING changed. The only change is, that the Faces shown up or not.
I copy/paste Models without this light bug for testing, and they even have the same Problem, if i rotate them. Are you sure that it has to do with the Normals?

ohh and by the way … sry for my bad english :slight_smile:

EDIT: Ok, it has definitly to do with Normals. But cant figure out what i am doing wrong :confused:
EDIT2: I ´ve solved my problem, i created own faces (with Polygone creator) above every Object in the Scene. This is very inconvenient and i am afraid that this caoused perfomance problems to my FPS in the Game …
Hope there is still another way to doing this :slight_smile:

The ceiling, floor, and picture on the wall don’t have normals facing out of them - this would explain the incorrect lighting/shadows. They need to be facing out like the walls on the sides.

@PhillyVanilly please post your images with, this pic-upload is really annoying.