Problems with starting the scene editor

I’m having trouble starting the scene editor. When I create a new scene and want to edit it SceneComposer I get a message saying “OpenGL context not started”. I’ve found this post on the forum (OpenGL Context Not Started.. Cannot use scene editor) but the Github wiki doesn’t work anymore and I couldn’t find a solution in the troubleshoot section (https://wiki.jmonkeyengine.org/sdk/troubleshooting.html). If it helps I’ve noticed the output terminal says “Could not find GLX 1.3 config from peer info”. I have tried running it on both Manjaro and Linux Mint.

OpenGL Context not started means trouble to use openGL at all. Usually when the SDK has problems, your applications should have as well.

Does invoking glxinfo or glxgears work? Sometimes it may be due to missing drivers, sometimes ppl run in a virtual environment or have no dedicated GPU at all, so creating the context fails.
What the 1.3 config wants to say, I don’t know, but maybe your GPU doesn’t support openGL2? (GLSL130?)

Edit: A quick google showed this: https://github.com/tectonicus/tectonicus/issues/60
Maybe installing the packages helps?

I have the same issue so I don’t use SDK (not an option for you I guess). The funny part is that, when I run jME app from eclipse, it works.

I had this issue and it weirdly had to do with the fact I had disabled my onboard sound.