Properties file not found

hey there

I installed JME, the latest eclipse, copied the dlls to the bin directory and imported the jars to my classpath. but when i try to start my hello world app, following error occurs:

20.08.2005 18:08:21 start
INFO: Application started.
20.08.2005 18:08:21 com.jme.system.PropertiesIO <init>
INFO: PropertiesIO created
20.08.2005 18:08:21 com.jme.system.PropertiesIO load
WARNUNG: Could not load properties: properties.cfg (Das System kann die angegebene Datei nicht finden)
java.lang.NoClassDefFoundError: org/lwjgl/LWJGLException
   at Source)
   at Source)
   at HelloWorld.main(
20.08.2005 18:08:21 cleanup
INFO: Cleaning up resources.
20.08.2005 18:08:21 com.jme.input.InputSystem getKeyInput
WARNUNG: KeyInput is null, insure that a call to createInputSystem was made before getting the devices.
20.08.2005 18:08:21 com.jme.input.InputSystem getMouseInput
WARNUNG: MouseInput is null, insure that a call to createInputSystem was made before getting the devices.
20.08.2005 18:08:21 start
INFO: Application ending.

You need to have lwjgl.jar in your classpath as well.

I believe that will be included in the libs directory of the jME download.


Try to run at first time:


it will create the properties.cfg

That's just a warning message, it doesn't really matter to the execution of his application.  The problem is following with the exception because he doesn't have LWJGL in his classpath.

problem solved… I guess I can start developing now…  This community is really frendly. thanks a lot

I've seen at least a couple of posts of people that had the same problem I'm having now. I have read them as well as the setup guide and am still struggling. I'm getting the properties.cfg file not found error. I'm new to jme, developing on Eclipse. I have downloaded the LWJGL libraries. My situation looks like this:

./projectfolder contains all the .java code of my project

./projectfolder/target contains all the jme jar files

./projectfolder/lib contains all the LWJGL stuff. LWJGL's zip file contains some subfolders, so I've included those subfolders here and just in case have aswell copied all the contents of those subfolders to the ./projectfolder/lib folder. Just in case I've included all of these (libs and jars) in the project so Eclipse does not complain before compiling. In the Run configuration I added to the classpath all the jar and libs and under Vm parameters entered: java -Djava.library.path=./lib -classpath


I'm desperate, why isn't it finding lwjgl.jar? I keep getting this:

Feb 5, 2006 7:23:36 PM start

INFO: Application started.

Feb 5, 2006 7:23:36 PM com.jme.system.PropertiesIO <init>

INFO: PropertiesIO created

Feb 5, 2006 7:23:36 PM com.jme.system.PropertiesIO load

WARNING: Could not load properties: properties.cfg (No such file or directory)

java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path

at java.lang.ClassLoader.loadLibrary(

at java.lang.Runtime.loadLibrary0(

at java.lang.System.loadLibrary(

at org.lwjgl.Sys$

at Method)

at org.lwjgl.Sys.<clinit>(

at org.lwjgl.opengl.Display.<clinit>(

at com.jme.system.lwjgl.LWJGLPropertiesDialog.<init>(Unknown Source)

at Source)

at Source)

at PlasmaWorld.main(

Feb 5, 2006 7:23:37 PM cleanup

INFO: Cleaning up resources.

Feb 5, 2006 7:23:37 PM com.jme.input.InputSystem getKeyInput

WARNING: KeyInput is null, insure that a call to createInputSystem was made before getting the devices.

Feb 5, 2006 7:23:37 PM com.jme.input.InputSystem getMouseInput

WARNING: MouseInput is null, insure that a call to createInputSystem was made before getting the devices.

Feb 5, 2006 7:23:37 PM start

INFO: Application ending.

Could anyone please show me how they've got their stuff organized (folder-wise) and referenced in java.library.path … i think i may be

referencing things wrong. Thanks.

The properties file not being found doesn't matter, it just happens to be right above the real error you are having.

It would seem you don't have the LWJGL DLL in your path correctly.  Verify there is a lib directory as a subdirectory to the directory you're running from, and that the directory has a "lwjgl.dll" if you're running on Windows.


wow darkfrog, thanks for your prompt response. Unfortunately I forgot to mention I'm on a mac, os X 10.4.4.

Looking inside the unziped folder (lib) i have subfolders: native, jar, doc and res. Within "navtive" I have a lot

of dylib and jnilib files. Would these be the equivalent to dll's on a mac?

Yes, jnilib and dylib files are the mac-equivalent to those windows dlls. Suited Mac-libraries should come with jME and are directly in its lib folder.

I keep forgetting about Macs. :-p  Linux coders never need this kind of help, I can't imagine why that could be.  :roll:


Thanks. If you took half a minute to read my original post however, you'd see I've been actually doing things the way the guide describes them. And please stop your prejudice against mac users/programmers. Have you even ever owned a mac?

It’s just darkfrog mmenchu, you’ll get used to him :wink:

Besides, we shouldn’t upset him right before the release of Rolling Raiders Roll-A-Rama

If you use jME from CVS all the needed libraries will be included and available under /lib (no need to download LWJGL then)

As for the problem you’re having now, you can solve it adding the right locations to -Djava.library.path=

Of course since you’re using Eclipse you can also let Eclipse make the build path and it can even set the -Djava.library.path= automatically, by specifying the “native libray location” when you’ve added a lib to Eclipse’s Java Build Path libraries (I haven’t seen that mentioned in any jME guides, but it works for me).

Prejudice against Macs?  Well, yes, I guess I am, but that entirely has to do with the proprietary nature of their business, it's just un-American.

However, in this case I was not attempting a dig at Macs.  I was just making an observation that the learning curve required to use Linux requires that you learn a lot of the common issues Windows and Mac users get stuck at.  So, in essence, it was a dig on both Macs and Windows…and I'm partially a Windows user myself. :-p

So no offense intended, and lighten up…games are supposed to be fun.  8)

Llama, want me to add a little easter egg in Roll-A-Rama that will change everything to say Rolling Raiders just for you?  …and it could play the WinAmp startup sound also! :-p


un-American like software patents and that like ?  }:-@

Don't get me started on patents…speaking of which, I need to finish my patent for "way of making lots of money"…I'm betting on that for my retirement. :-p


doh  :-o  paying license costs if making lots of money  :-o

heck ok, please stay busy developing jme - apps and stop scaring innocent non-Americans :slight_smile:

non-Americans are never innocent…speaking of which, Americans are never innocent either. :-p


Well, getting JME to compile was definately frustrating. But more frustrating pherhaps was having all the arrogant “non non-americans” oh-so-wise-linux-gurus giving suggestions bashing on mac users without thinking that maybe macOS X actually requires more tweaking to do than linux. Anyway, I got things going and no, it wasn’t because I didn’t know some idiotic library/class path command. So, for folks on macs here’s my advice:

First forget about adding the Djava.library.path thing to eclipse (assuming that your IDE of choice). Just import eveyrthing under the JME folder in the project. This will allow you to compile. However it won’t allow you to run.

After googling like crazy (probably about 4 hours total) the instructions here: seemed to help the most. At least they got me into the right direction. Apprently to some guys it worked just to drop the contents of jME/lib into Library/Java/Extensions. If this solves your problem great. If not then follow with me. Mac OS X comes by default (or at least did) with java 1.4. I installed 1.5 from the apple website a while ago and specified Eclipse to compile with it. So, check what version are you trying to compile with (in my case 1.5.0) and depending on that go to System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Libraries and dump there all the contents of JME/lib. This solved my problem.  if for some reason this still does not solve yours, i suggest you trying with all possible library folders you can think of. Now this isn’t necessarily the best thing to do, but hey, if you want to get things going give it a try at least. Hope this helps.

Okay, well, I guess I'll abstain and divert to what Llama says:

It's just darkfrog mmenchu, you'll get used to him


You'll get used to me aswell Darkfrog  :smiley: hehe. Thanks anyway.