Reduce jitter for "sliding" objects?

I found out that I can attach multiple capsule shapes to get quite smooth sliding effect for like “objects on ice” but the capsules have quite a noticable performance impact. Insted I’d rather use box shapes but these “get cought” once in while on pefectly flat ground? That’s what I mean by “jitter”. So can I tell the physicis engine somehow to create less “jitter”?

Don’t use a large box or quad, use a plane or a proper mesh as floor.

Hmm… I don’t actually have a floor my level consists mainly out of static cubic platforms and is imported from blender. So I’m quite lost here, is there no alternative? Some settings I could try maybe? I tried giving the platforms more polygons but this doesn’t seem to help either?

Subdivide the platforms in blender.

I had this same problem, this solved it for me. yourbulletappstate.getPhysicsSpace().setAccuracy(0.001f).